Mass Effect > General Discussions > Topic Details
The Seemingly Innocuous Squid Aug 16, 2014 @ 9:39am
Low framerates on a somewhat mid-end PC
To be blunt, this game runs horrible for some strange reason. I see constant frame rate drops when exploring uncharted planets (Around 30-25FPS), exploring The Presidium/Wards (25-15FPS), and when engaged in combat (Framerate varies depending on where I am, but it's mostly around 30-25 FPS). The lowest was during the final boss fight (12-8FPS!!).

Oddly, conversations and cutscenes are always running at 60FPS. In addition, sometimes when I save the game, I notice the framerate skyrocket to 60FPS; only to plummet to 40-30FPS.

Settings I'm playing on:
Resolution: 1280x720
Textures: Ultra High
Particles: High
Filtering: Anisotropic
Dynamic Shadows on
Motion Blur/Film Grain on
Vsync on

My specs (possibly mid-end):

Windows XP SP3 (Yes I still use it; can't upgrade my OS anytime soon.)
Intel Core 2 Quad Q6600 2.4GHz (OC'd to 3GHZ)
EVGA GeForce GTX 650 1GB DDR5 (Non Ti) Running on 340.52 drivers
3GB DDR2 RAM

Tried everything from lowering the graphic settings, ini tweaking, defragging hdd, updating drivers, and cleaning my registry. Still getting the same framerates.

Also, this game runs on the Unreal Engine 3. I'd like to point out that I own numerous UE3 games that run better than this game.

Examples: Mirror's Edge (Always at 60FPS), Borderlands (60FPS with shadows disabled), Mass Effect 2&3 (Mostly 60FPS), Batman AA & AC (AA: Mostly 60FPS, AC: Mostly 60FPS) etc. All are running on high settings at 720p.

Mass Effect is the only UE3 game that I'm having issues with.

Any help is well appreciated.
Last edited by The Seemingly Innocuous Squid; Aug 16, 2014 @ 9:40am
Date Posted: Aug 16, 2014 @ 9:39am
Posts: 0