Mass Effect > General Discussions > Topic Details
Aegypticus Aug 12, 2014 @ 6:20am
Won't Launch
Everytime I try to play Mass Effect, it says that it has stopped working, I have looked around and have tried all the I saw. Any help?
Showing 1-13 of 13 comments
< >
meadowsrook Aug 12, 2014 @ 11:06am 
Same, tried it on dell with 7 and mac boot camp with 8 and same error on each one. Tried complete delete and redownload, tried appache folder trick. nothing.....

Bump..
G4vin44 Aug 12, 2014 @ 11:56am 
I was having a problem earlier, it might be similar to yours. What fixed it for me was downloading an update/patch from the BioWare website: masseffect.bioware.com/me1/pc/updates/index.html
It wasn't obvious that I needed this and it took me a while to find but it worked for me. Hope it helps.
Last edited by G4vin44; Aug 12, 2014 @ 11:57am
Number2boy Aug 14, 2014 @ 4:16am 
Originally posted by G4vin44:
I was having a problem earlier, it might be similar to yours. What fixed it for me was downloading an update/patch from the BioWare website: masseffect.bioware.com/me1/pc/updates/index.html
It wasn't obvious that I needed this and it took me a while to find but it worked for me. Hope it helps.

I tried that update but it still does not launch for me
Last edited by Number2boy; Aug 14, 2014 @ 4:17am
willmiller3 Aug 15, 2014 @ 2:04pm 
Originally posted by Number2boy:
Originally posted by G4vin44:
I was having a problem earlier, it might be similar to yours. What fixed it for me was downloading an update/patch from the BioWare website: masseffect.bioware.com/me1/pc/updates/index.html
It wasn't obvious that I needed this and it took me a while to find but it worked for me. Hope it helps.

I tried that update but it still does not launch for me

Did you try running it in compatibility mode and then running the update?
j.sd Aug 16, 2014 @ 2:16pm 
try this go to : C:\Program Files (x86)\Steam\SteamApps\common\Mass Effect\Binaries <-- or the folder steam installed mass effect on your computer. Find the main binary file named "Mass Effect" right click --> property's ---> run as admin.

hope it helps xx

Enter Mask Aug 17, 2014 @ 9:34am 
You shouldn't need to run it as admin. Just right click the mass effect exe file, click on properties, go to compatability mode, and then choose XP (service pack 2 or 3 should do). It ran perfectly after I did that on windows 7.
Last edited by Enter Mask; Aug 17, 2014 @ 8:10pm
mcarlozzi21 Aug 17, 2014 @ 2:50pm 
Just downloaded the game, had the same issues as the guy above. The "run as admin" option didn't work, but when I tried the compatability option, it did. Thanks to the guy who recommended that.
meadowsrook Aug 18, 2014 @ 6:34pm 
Compatability worked for me as well, kudos to Will.
CountZero Aug 19, 2014 @ 11:24am 
Don't download the patch, as that is a fix for Mass Effect on Origin. If you did, you can verify the game cache to return the game back to its original steam downloaded state.

Try the tips listed here: http://pcgamingwiki.com/wiki/Mass_Effect#Game_simply_doesn.27t_start

For me, installing the legacy PhysX drivers for my Nvidia card was the trick that got the game to work.
Last edited by CountZero; Aug 19, 2014 @ 11:25am
Mattman Aug 20, 2014 @ 4:28am 
Originally posted by Enter Mask:
You shouldn't need to run it as admin. Just right click the mass effect exe file, click on properties, go to compatability mode, and then choose XP (service pack 2 or 3 should do). It ran perfectly after I did that on windows 7.

This worked for me as well.
rediron81 Aug 20, 2014 @ 2:19pm 
On windows 8, I just had to launch Steam (not Masseffect.exe) as admin then launch ME normally. Worked for me.
Jr786 Neil Watts/Eva Rosalene Aug 21, 2014 @ 8:18am 
On Win7, use the backwards Compatabilty Mode.
Velkrö Aug 25, 2014 @ 9:54am 
Originally posted by Enter Mask:
You shouldn't need to run it as admin. Just right click the mass effect exe file, click on properties, go to compatability mode, and then choose XP (service pack 2 or 3 should do). It ran perfectly after I did that on windows 7.


Thx this work
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Aug 12, 2014 @ 6:20am
Posts: 13