rfickel1985 Mar 4, 2013 @ 3:57pm
No CD?
I bought this game a while back, but my computer at the time wasn't quite good enough. So I waited. Now with the new computer, it should be good enough, but I get a No CD error every time I try to run it. Does anyone know how to fix this? I bought it off steam, so of course there's no CD.
Showing 1-12 of 12 comments
< >
Fap4life Mar 6, 2013 @ 5:47am 
Reinstal, if this does not help, contact steam support.
rfickel1985 Mar 6, 2013 @ 6:05pm 
Tried reinstalling. And steam support has thus far been silent. Oh well, figured it wouldn't hurt to ask here.
Flatfire Mar 9, 2013 @ 6:24pm 
Does the error say "no disk in drive" and gives you a location like "/devices/harddisk/dr8" or something?
rfickel1985 Mar 9, 2013 @ 9:37pm 
I'll have to reinstall to verify, which I'm doing anyway since Steam Support wants a screen shot, but no to the second part. It gave me a drive letter, and then cycled through several drive letters even if there were no drives assigned to those letters. So "No disk in drive F:" then G, H, I, J....... till it eventually stops responding and I have to kill it.
Flatfire Mar 10, 2013 @ 8:24am 
Weird, I had the error I defined above. I fixed it by reinstalling some redistributable packages found in the mirrors edge folder. Try that first then restart your computer. So far though I haven't seen much to cover these problems on the web
rfickel1985 Mar 10, 2013 @ 2:31pm 
Out of curiosity, are you running Windows 8? I kind of wonder if it's a compatability issue with the new OS. The game worked fine on 7, aside from my old computers lack of ability to run it smoothly that is.

Well, it finished reinstalling last night, now I don't even get the same error message. Just "This program is not responding." Yay fun!

Anyway, I'll keep working on it. I'll look into what you suggest, and perhaps seeing if 8's compatability troubleshooter is any better then 7's.
Flatfire Mar 11, 2013 @ 6:35am 
I'm using Windows 7. But keep working, I don't know what the issue is now at all but good luck.
ALP ALFIE Mar 11, 2013 @ 11:38am 
same thing happened to me i cant get it working because i dont have a disk but i bought it of steam
Foobie Mar 28, 2013 @ 7:45am 
Just wanna say, i'm suffering this too. Also Windows 8, i've tried all of the above, and it still doesn't work.
Fap4life Mar 28, 2013 @ 7:50am 
@foobie
Can you run it in compatibality mode?
Foobie Mar 28, 2013 @ 9:39am 
D'oh, yep, that did it, Compatibility Mode: Windows 7 works fine. Can't believe i didn't try that!

Thanks for the suggestion!
Fap4life Mar 28, 2013 @ 12:37pm 
No Problem :)
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Mar 4, 2013 @ 3:57pm
Posts: 12