Mirror's Edge

Mirror's Edge

WackoLlama May 10, 2013 @ 5:58am
Mirrors Edge wont start
Every time I try to launch Mirrors Edge and click Play, nothing happens. I've kept an eye on my task manager and see that Mirrors edge starts to run but closes it self before anything comes up. I have tried fixing the resolution and even tried to download the Physx thing.

I have run Mirrors Edge before on my computer so my specs shouldn't be an issue.
I'd love for somone to be able to help me with this because this game is so awesome.

< >
Showing 1-15 of 44 comments
Lame Sauce May 16, 2013 @ 10:49am 
I am having this exact same problem. I have never been able to play this game because of this problem.
Sesh May 17, 2013 @ 1:41am 
Try either disabling NVidia physx or getting a driver that supports it.
Lame Sauce May 22, 2013 @ 1:10am 
My drivers are up to date, and I disabled the physx engine and I am still having the same problem. Wackollama is that true for you as well?
WackoLlama May 22, 2013 @ 2:07pm 
Yeah Same for me/
Sesh May 23, 2013 @ 2:18pm 
Physx is an old system and you may need to specifically download a driver for it. It isn't supported by modern graphics cards, and may bring with it files that Miror's Edge is looking for. Downloading a driver specifically for Physx made my game run but I still had to disable Physx.
DuckRustler May 23, 2013 @ 7:26pm 
This is what it says at PC Gaming Wiki

Install the latest Nvidia PhysX System Software regardless of whether you are using an Nvidia, AMD or alternative graphics card.

AMD Radeon and alternative GPU users who are able to start the game using this method are then advised to disable PhysX in the options menu.

Your monitor may not be supported. Open the engine config file (%USERPROFILE%\My Documents\My Games\EA Games\Mirror's Edge\TdGame\Config\TdEngine.ini) and change the resolution. Look for ResX and ResY in [SystemSettings] section) to one supported by your monitor (try 1024x768 if you don't know what your monitor supports)

Not sure if it helps you.
Chinex May 25, 2013 @ 9:41am 
You have to edit the TdEngine.ini archive that usually are in C:\Users\"Your User"\Documents\EA Games\Mirror's Edge\TdGame\Config and go to the ResX and ResY and put your native resolution....
WackoLlama May 25, 2013 @ 9:50am 
I have this game through Steam so I don;t have an EA Games file. If I try to alter the files steam throughs a hissy fit and says I've ruined the integrity of the files.
Abyss_Walker May 27, 2013 @ 4:01pm 
I'm having the same problem, it makes no sense. I played the game for about an hour a few months ago, now it won't start.
Abyss_Walker May 27, 2013 @ 6:41pm 
This method fixed it for me: copy Mirror's Edge\Binaries\PhysXLocal\PhysXLoader.dll and paste it in Binaries folder and start game
ando2011die May 31, 2013 @ 9:38am 
The Binaries file is emptey for me
Abyss_Walker May 31, 2013 @ 1:00pm 
When I go into C:\Users\My Name\ My Documents\ EA Games\ Mirrors Edge\ Binaries, THAT folder is empty. But that's not where my steam apps are, I forget what that folder is even for.

Go to where the games actually installed, like in my case its in H:\SteamLibrary\SteamApps\common\mirrors edge\Binaries\PhysXLocal.

In PhysxLocal you'll find the PhysXLoader.dll, copy that, and paste it into \SteamApps\common\mirrors edge\Binaries.
Last edited by Abyss_Walker; May 31, 2013 @ 2:38pm
Mr. Smooth Jun 1, 2013 @ 5:53am 
me too!!
AZ Jun 29, 2013 @ 5:38am 
thanks to the guy telling to change resoloution because in the file mine was 1600-800 this really helped thank you!! XD
< >
Showing 1-15 of 44 comments
Per page: 15 30 50

Date Posted: May 10, 2013 @ 5:58am
Posts: 44