graveyjones Apr 11, 2013 @ 10:38pm
Huge frame rate issues
Hi
every second level my frames drop to an unplayable level, i trun my grapics down but it doesnt change a thing.
please help me with a soultion.
Showing 1-15 of 25 comments
< >
SavageSoldier Apr 12, 2013 @ 10:15am 
What are your specs?
nanto.seiken Apr 12, 2013 @ 10:34am 
same problem here. runs on an intel core i5 3470, gpu is a gigabyte radeon hd 7950. it's literally unplayable...
HowlingWolf Apr 12, 2013 @ 11:37am 
Same here, i7-3610QM, Nvidia GT630M 2Go, 8Go RAM.
The Clash At Demonhead Apr 12, 2013 @ 11:56am 
I had a similar problem until i turned physx off
Dick Dousche Apr 12, 2013 @ 1:10pm 
PhysX being turned on causes all the frame rate issues. disabling it will help you run the game much smoother
Last edited by Dick Dousche; Apr 12, 2013 @ 1:11pm
nanto.seiken Apr 12, 2013 @ 1:29pm 
thanks for the help, much appreciated!
graveyjones Apr 12, 2013 @ 3:52pm 
thanks guys
Conan Apr 12, 2013 @ 9:27pm 
If you have an AMD/ATi gpu turn physX off and that should fix it.
Lord Maximus Apr 13, 2013 @ 3:28pm 
I have 2 GTX 680's, i7 3770k, 32GB Ram.... I'm also having fps drops to unplayable levels (mostly when the helicopter is shooting out glass windows on the 2nd level). There's no reason I should have to turn physx off to run this game smoothly with my specs. This is ♥♥♥♥♥♥♥♥.
BDK Apr 13, 2013 @ 4:23pm 
Originally posted by BL00DYF@CE:
I have 2 GTX 680's, i7 3770k, 32GB Ram.... I'm also having fps drops to unplayable levels (mostly when the helicopter is shooting out glass windows on the 2nd level). There's no reason I should have to turn physx off to run this game smoothly with my specs. This is ♥♥♥♥♥♥♥♥.
Physx is overrated, just turn it off and stop complaining.
Flatfire Apr 13, 2013 @ 9:25pm 
PhysX ruins just about every game that supports it. To be honest, even if your card supports it, nVidia did an awful job with it.
jzpotter Apr 16, 2013 @ 5:24am 
Turn off PhysX.
HunterKiller Apr 18, 2013 @ 8:58am 
I had some problems earlier, more-so when, the police are chasing, helicopter is shooting out glass windows and shooting @ her.

FX6860
i7-2600 CPU @ 3.40 GHz, 3401 Mhz, 4 Core(s) 8 Processors (x64) 1.5TD HDD
16GB DDR3 RAM
AMD/ATI 6750 Radeon HD Series
1600 x 900 x 60 hertz

Np with any other games in this sense of having problems. Just this one.



Last edited by HunterKiller; Apr 30, 2013 @ 3:37pm
Fap4life Apr 18, 2013 @ 9:49am 
You do have physx disabled?
And on what are you running it? everything on high?
HunterKiller Apr 18, 2013 @ 9:52am 
AMD doesn't have Physx like nVidia does. Desk Top Gamer.

Ok, I just checked in game and it was on. Odd, most other games, it's off. I'll see what happens now. Thanks.
Last edited by HunterKiller; Apr 18, 2013 @ 9:56am
Showing 1-15 of 25 comments
< >
Per page: 15 30 50