DarkDexter Apr 21 @ 8:20am
Will not launch or do anything
I have read some posts similiar to my problem but nothing has fixed it yet. Please help. I uninstalled and re-installed. Validated files many times. Ran CC Cleaner. I put a few hours into this game and had no problems. I stopped playing for quite a while and had the urge to play again. This has been happening a lot with my steam games when I dont play them for a while but usually I just validate files and it works. Not this time. Any other suggestions? Thank you for your help
Showing 1-3 of 3 comments
< >
DarkDexter Apr 21 @ 8:28am 
Ok I tried this and it worked for me

Yup, this fix does indeed work. Mirror's Edge stores its own PhysX drivers when your native PhysX is missing or broken, but these are outdated and so will either not work at all or have terrible lag spikes, even on the fastest of Nvidia cards.

If you are an AMD user, try going to 'SteamApps\common\mirrors edge\Binaries\PhysXLocal' and copy the contents of the folder to 'SteamApps\common\mirrors edge\Binaries'. Not sure if this works, but this should force Mirror's Edge to recognise its own PhysX if it hadn't already.
Aunt Jemima Jul 1 @ 1:29pm 
THANK YOU!
RotatableAxle Jul 2 @ 6:38pm 
I have the same problem, is the fix the same on nvidia cards too?
Showing 1-3 of 3 comments
< >
Per page: 15 30 50