Cynder Jul 4 @ 11:55pm
Massive frame rate drop with PhysX
I've tried installing the legacy drivers and renaming/deleting the PhysXcore.dll, PhysXdevice.dll, and PhysXloader.dll files.

If I mess with the dll files mentioned above the game will not launch at all. In order for me to launch the game I have to have all three of those files in the binaries folder.

Turning PhysX off does fix the issue, but I just want to know if there is a workaround for this as this is one of the games I looked forward to using the PhysX effects on when I built my PC.

Im using an MSI GTX 760 4GB RAM.

Showing 1-8 of 8 comments
< >
Rarewolf Jul 4 @ 11:59pm 
you should also give the rest of your specs.
nuh1 Jul 5 @ 12:00am 
http://steamcommunity.com/app/17410/discussions/0/540744934991380592/
The files were:
PhysXcore.dll
PhysXDevice.dll
PhysXLocal (folder)
Make sure you are renaming/deleting those specific ones. Basically the PhysXExtensions.dll should be the only thing in your binaries folder that has the name PhysX in it.
http://steamcommunity.com/sharedfiles/filedetails/?id=170559843
Last edited by nuh1; Jul 5 @ 12:03am
Хрю-хрю Jul 5 @ 12:53am 
Go on Nvidia Panel, open PhysX settings. Choose PhysX on GPU. Not on CPU or AUTO.
http://i.stack.imgur.com/CdmGj.png
Cynder Jul 5 @ 9:59am 
AMD FX 8350 8 core 4 GHz processor
ASRock Fatal1ty 990FX Killer Motherboard
MSI GTX 760 4GB VRAM GPU
16 GB RAM

I have ensured that the PhysXExtensions.dll is the only file with PhysX in its name in the binaries folder, and if I do that my game will not launch, no black screen or anything. It immediately comes up with window saying that ME has stopped working.

If it helps I also had the issue where the PhysXloader.dll file had to be moved from the PhysX local folder up into the binaries folder.

WIthout the loader, core, and device .dll files in the binaries folder, my game will not launch.

Setting PhysX to GPU as suggested above did not fix it either.
nuh1 Jul 5 @ 11:08am 
Have you tried reinstalling physx? like the ones from the nvidia website.
Cynder Jul 5 @ 3:12pm 
Re installing PhysX didn't fix the frame rate drop issue.

At least I am still able to play the game as long as PhysX is turned off, it would just be nice to have it enabled.
Cynder Jul 6 @ 11:50pm 
I finally got this working. After installing some PhysX drivers that were linked to for another game, Mirror's Edge finally let me delete those pesky .dll files. Now the game runs just fine with PhysX enabled.

Thanks for your help everyone!
Try to reinstall from the Nvidia physx from Nvidia website.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50