Spore > General Discussions > Topic Details
Resonator Apr 19, 2013 @ 1:49am
Spore launch errors, PLEASE HELP!
So I just bought Spore and the Galactic Adventures expansion. I'm running on Windows 7 64-bit and I've tried installing / uninstalling Spore 3 times now because I continuously get the same 2 errors on launch;

- Configuration Script Failed [2000]
- Could not find a needed package. The data directory is missing or corrupt. [1004]

I'm having trouble finding solutions online, I've tried deleting my registry and different compatibility modes to no avail. Does anybody have any idea on how to fix this?
Showing 1-15 of 243 comments
< >
Resonator Apr 19, 2013 @ 4:30am 
bump, I really need help, I want to play some Spore!
McGunns Apr 19, 2013 @ 2:16pm 
I checked the Spore forums, because I too were having the exact same errors and this is what I found.
It is due to 64 bit Window 7 registry deleting the SPORE entries automatically after each installation and patching.

HOW TO FIX SPORE for 64 bit Windows 7
1. Open C:\Windows\regedit as administrator

2. Find
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Electronic Arts\SPORE

3. Add the following as string value if they are not there
AppDir = SPORE
DataDir = C:\Program Files (x86)\Electronic Arts\SPORE\Data\
InstallLoc = C:\Program Files (x86)\Electronic Arts\SPORE
PlayerDir = My Spore Creations

4. Add the following as 32bit DWORD value
ReIndexYesOrNo = 0
InstallCompleted = 1

5. Open Spore and have fun

Note: change the blue text to your installation directory, the one shown is the default directory

>blue text was the c:\ files next to DataDir and InstallLoc
I tried looking for the exact place but I couldn't find the files to change.

Maybe you will have more luck
GL_DONT_CARE Apr 19, 2013 @ 5:12pm 
THANK YOU McGunns! IT WORKED!

I changed:

AppDir = Spore
DataDir = D:\Games\Steam\SteamApps\common\Spore\Data\
InstallLoc = D:\Games\Steam\SteamApps\common\Spore

All is well now! Thanks so much!
[NIA]Capt. Chris Jun 28, 2013 @ 10:48am 
Awesome, this works! Great job!
A Dog Jun 28, 2013 @ 11:01am 
McGunns do u know how to fix it for vista
Toasty Jun 28, 2013 @ 12:01pm 
Hmmm, I can't seem to find Spore under Electronic Arts.
A Dog Jun 28, 2013 @ 1:23pm 
i cant find Wow6432node
Toasty Jun 28, 2013 @ 1:25pm 
Originally posted by Sevz Teh Frisky Kitten:
i cant find Wow6432node
It should be at the very bottom of software, at least it was for me.
A Dog Jun 28, 2013 @ 1:27pm 
its not there
Grim Jun 28, 2013 @ 1:27pm 
i cant find the Electronic Arts folder anywhere
A Dog Jun 28, 2013 @ 1:29pm 
at the bottom of mine is ZSMC
Tuska Jun 28, 2013 @ 1:56pm 
Toasty same here i cant fine spore under electronic arts
alexbshuford Jun 28, 2013 @ 1:57pm 
Does anyone know how to fix on windows 8 ????
i dont even have an electronic arts folder
Numn Nutts Jun 28, 2013 @ 2:08pm 
Im on Windows 7 and I dont have a Spore folder under Electronic Arts.
Numn Nutts Jun 28, 2013 @ 2:10pm 
Originally posted by Toasty:
Hmmm, I can't seem to find Spore under Electronic Arts.
Thats what Im saying.
Showing 1-15 of 243 comments
< >
Per page: 15 30 50
Date Posted: Apr 19, 2013 @ 1:49am
Posts: 243