Crysis > General Discussions > Topic Details
CJ RageGamer Sep 7, 2012 @ 8:05pm
Crysis, Crysis Warheads, and Crysis Wars all not working.
I finally was able to get Crysis thanks to the Steam sale, finally got all of them downloaded, and now every single one doesn't work.

All 3 just tell me "Crysis has stopped working" and exits. I've searched all over the internet and have found no solution. Deleting the save files does nothing. I tired compatibility mode and run as admin and nothing at all works.

My specs:
Windows 7 64bit
AMD 4100-FX 3.8GHz
ATI Radeon HD 6670
8GB RAM
Last edited by CJ RageGamer; Sep 7, 2012 @ 8:13pm
Showing 1-15 of 52 comments
< >
CJ RageGamer Sep 7, 2012 @ 8:13pm 
Also, after reading through here, everyone has been posting the same link to some thread that supposedly fixes everything but it's always invalid request. I would greatly appreciate some help with this.
torture_tactix Sep 7, 2012 @ 9:13pm 
I have the same problem

win 7 64bit
amd fx-8120
radeon 6950
8gb ram
keithj Sep 8, 2012 @ 12:14am 
same here.

win 7 64-bit
i7
gtx 680
16gb ram
Mifel Sep 8, 2012 @ 1:43am 
same here!

win 7 64-bit
amd 6100
radeon hd 6950
8gb ram
Loco Sep 8, 2012 @ 1:54am 
same here....

WIN XP Pro Service Pack 3
Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
GeForce GTS 250
2 GB RAM

only difference: no message, nothing, when i click play, it starts loading for about 3-4 seconds, and then it finish. no screen changes no error messages
BulldoG Sep 8, 2012 @ 2:55am 
Just posting my experience to see if it helps others

Running Win7 64bit
Athlon II X-3 440
Radeon HD4350
4GB ram

Game ran first time & yeah I need a faster GFX card but it works pretty well as is.

Did you guys install the gamespy comrade crap? I did.
Also I have read around that DX9 may help out even though it runs on DX10 AFAIK.
I already had DX9 installed anyway, so could be another fix?

Other suggestions are compatibility mode
gh7531 Sep 8, 2012 @ 3:09am 
Same Here after start i got a blackscreen -.-

Win7 HP x64
AMD FX-4100
Radeon HD6450 ^^
4GB DDR3 Ram

May it is because AM3+? I know that Portal2 make problems with AM3+
Sry for bad english :)
Circumambient Sep 8, 2012 @ 5:15am 
Same here!
Have no idea why, really wanted to play -_-
Fin Sep 8, 2012 @ 5:45am 
Im having the EXACT same problem im glad its not just me!
wichu Sep 8, 2012 @ 5:50am 
same problem
Win7 64-bit
FX-8150
radeon HD6950
8GB Ram

Black screen after pressing "PLAY", in background "Crysis has stopped working". Compatibility mode is not helping, admin, aero..... nothing.
The Swedish Chef Sep 8, 2012 @ 5:53am 
Are you running AVG antivirus? The below thread has a fix that worked for me.

http://steamcommunity.com/app/17300/discussions/0/864945309941708728/
Fin Sep 8, 2012 @ 6:07am 
i tried the AVG thing and it made no difference
TAki Sep 8, 2012 @ 7:51am 
i don think anyone can help fix this nothing works...
CJ RageGamer Sep 8, 2012 @ 10:56am 
I've been trying the official site but they are of no help. Seems like they don't care about their Crysis game since they're working on Crysis 3.
Fin Sep 8, 2012 @ 12:10pm 
try going into my documents my games then deleting the files in the profiles folder, OWRKED FOR ME!
Showing 1-15 of 52 comments
< >
Per page: 15 30 50

Crysis > General Discussions > Topic Details
Date Posted: Sep 7, 2012 @ 8:05pm
Posts: 52