Crysis > Allgemeine Diskussionen > Themendetails
PcGamingRig 1. Feb. 2013 um 15:58 Uhr
My Crysis FPS Didn't Improve with Crossfire
Hi

Here are my specs:

Q6600 Quad Core OC @ 3.6 Ghz
AMD 6950 2GB Crossfire
6GB DDR2 Kingston Hyper X RAM @ 1200 Mhz

There was no improvement in my FPS when I added the second 6950 today...


I still get around 25 FPS on the GPU benchmark.

Any idea why it had no affect?

Thanks
Beiträge 1-8 von 8
< >
PcGamingRig 2. Feb. 2013 um 5:43 Uhr 
I have tested my crossfire on other games and there is a vast improvement so it is definitely only a crysis issue.
IceHandz 2. Feb. 2013 um 14:21 Uhr 
most games don't make use nor take advantage of multiple GPUs yet. I believe Crysis is one of those game that doesn't support multiple GPUs. It's a pretty old game. Crysis 3 was built to run on multiple GPUs however. Test it on the beta.
SevR 3. Feb. 2013 um 10:44 Uhr 
Make sure your antiquated chipset can utilize the x-fire. Look at BIOS updates from your mobo manufacturer.
PcGamingRig 3. Feb. 2013 um 12:20 Uhr 
my mobo definitely can use crossfire and like i said it has worked in other games. the only one I am having trouble with is crysis.
SevR 3. Feb. 2013 um 14:21 Uhr 
Maybe AMD doesn't have optimizations for x-fire and Crysis on any system thats not their Spider Platform. We are talking circa roughly '07, thats 5 years, so 10 tech development years.
PcGamingRig 4. Feb. 2013 um 3:29 Uhr 
it seems to work a bit better on the 32 bit version than the 64 bit version and i suppose my processor could be holding it back a bit, maybe a little bottleneck on my cards. and like you said the optimization might not be that great.

im upgrading to an i7 soon so i'll try it again then. :)
trackmania101 6. Feb. 2013 um 4:34 Uhr 
Crysis has a Graphic Specification issue, so some (like yours) Multi-GPU setups won't work. Its a Crysis 1 thing though.
miles82 10. Feb. 2013 um 11:31 Uhr 
The only reason I could see you getting worse performance is you're running out of VRAM. This was an issue I was having with my SLI GTX 460s. It could just be a CPU bottleneck though. Do you have the Rygels Texture pack? It might help if you created a RAM disk and put the texture files on the RAM disk and then create a symbolic link to them. This worked with one of my friends and he had a gtx 570 which has about 1.2GB of VRAM.
Beiträge 1-8 von 8
< >
Pro Seite: 15 30 50
Geschrieben am: 1. Feb. 2013 um 15:58 Uhr
Beiträge: 8