Crysis > General Discussions > Topic Details
Lord Westall Jan 28, 2013 @ 4:34pm
connection problems
when i try to star crysis a window pops up saying the dame needs acces to the internet in order to verify ownership of this game, even though i am connected to the internet. How do i fix this problem?
Showing 1-15 of 38 comments
< >
Jackknife Jan 28, 2013 @ 4:38pm 
yeah im getting this too.... its pissing me off

And before anyone asks:

1.) Antivirus and Windows firewall is not to blame
2.) Verifying cache didnt work

I was playing this fine last night and then i get that stupid message like this guy :

http://forums.steampowered.com/forums/showthread.php?t=3067909
Last edited by Jackknife; Jan 28, 2013 @ 4:40pm
gdgiordano Jan 28, 2013 @ 5:18pm 
Same problem with me! and thanks you @ JackKnife.... i tried those too! Im so mad... ive rebooted as well. only difference for me is this is a fresh installl...
gdgiordano Jan 28, 2013 @ 5:18pm 
and for the record im talking about just crysis one!
_Apocalipse_ Jan 28, 2013 @ 7:44pm 
Same ♥♥♥♥ing problem here...
I Have unistalled this ♥♥♥♥ and downloaded again 3 ♥♥♥♥ing times...and nothing work -.-
Last edited by _Apocalipse_; Jan 28, 2013 @ 7:45pm
Jackknife Jan 28, 2013 @ 7:51pm 
glad its not just me haha
thumbslinger Jan 28, 2013 @ 8:09pm 
I'm also having this problem and the game was working fine last night. I have a feeling their servers are down. Hopefully waiting it out will solve the problem. I know they are trying to stop pirates and all, but legitimate buyers are getting caught in the crossfire.
gdgiordano Jan 28, 2013 @ 9:41pm 
yeah im mad I just baught the game and cant play :(
Hoopy Frood Jan 28, 2013 @ 9:43pm 
Same problem here.

Why do companies still have DRM when they release for Steam? (I mean, besides being lazy. OK, so it's rhetorical.)
Roland of Gilead Jan 28, 2013 @ 10:10pm 
I was just playing.

Have you pirated any EA games in the past? Those stupid hacks they use to get around the DRM usually jacks up your registry.
Hoopy Frood Jan 28, 2013 @ 10:24pm 
Nope. Never pirated an EA game in the past.

And I contacted EA and they claim it's a Steam problem. Odd, because I don't recall Steam updating anything connected to this game recently. And I had no problems connecting yesterday.
Hoopy Frood Jan 28, 2013 @ 10:26pm 
Plus, are you really implying that everyone in this thread with the same problem are pirates? Broad brush, much?
« ₯ » Moonshine Jan 29, 2013 @ 1:17am 
having the same issue here. ive tried deleting clientregistry.blob, disabling firewall, antivirus, etc. .
Tiaryn Jan 29, 2013 @ 5:16am 
♥♥♥♥♥♥♥♥... (posting something to subscribe this discussion^^)
frodo-64 Jan 29, 2013 @ 5:27am 
same problem
chrisngeneos Jan 29, 2013 @ 8:46am 
geneo440 had 2 techs 4 2 hours no luck Im having same problem
Showing 1-15 of 38 comments
< >
Per page: 15 30 50
Date Posted: Jan 28, 2013 @ 4:34pm
Posts: 38