Crysis > General Discussions > Topic Details
Chalupa007 Jan 5, 2013 @ 1:31pm
Crysis 1 Crashes on start
I just bought the game last night because it was on sale for $5. Downloaded and was excited to play because I never played the game before. I have spent hours this morning trying to get the game to work. When I launch the game it goes full black screen I have to open task manager and end the program because it stops responding. I had the problem with Max Payne and was fixed with a system restart. Well this on wasn't. I than went online and found numerous forums of people having simular trouble I edited the compatibility to Windows Vist SP 2 deleted the profiles and tried to get a windows 64 bit install as well as the recent patch. After all this work not one thing works. I checked the games GPU support and it didnt have my GPU in their. I hope this isnt the problem because my GPU wasnt cheap.

My specs
Nvidia GTX 660 TI
AMD 8 core processor 3.1 GHZ
8 GB DDR 3 RAM
1TB of memory (500 GB free)
Showing 1-15 of 40 comments
< >
Cloudsol Jan 5, 2013 @ 1:58pm 
Probably because this version of Crysis is not 64-bit friendly. And for some reason Steam (and EA/Origin) refuse to work together to satisfy us (the customer). It is a sad and pathetic situation that will probably never be resolved.
Chalupa007 Jan 5, 2013 @ 2:09pm 
So am I SOL? Or is there a download link that I can get the 64 bit one. The steam and origin dispute is the bigges bulls*** I ever heard of. I wish origin would just bring everything here. I am annoyed because this isnt the first game I had the problem with.
Cloudsol Jan 5, 2013 @ 2:11pm 
You can try the 64-bit fix, I guess. Doesn't work for me though.
Chalupa007 Jan 5, 2013 @ 2:16pm 
Were can I find the download. I had found 1 but it was removed because it used copywrted info
Chalupa007 Jan 5, 2013 @ 2:19pm 
Thanks I am gonna give it a try
Chalupa007 Jan 5, 2013 @ 2:34pm 
This is rediculous I reinstall tried in running in 64 bit. Nothing My GPU isnt listed under ocmpatble gpus thats the only problem I can see
Cloudsol Jan 5, 2013 @ 2:40pm 
It's not your GPU. This version just isn't compatible with a 64-bit OS.
Chalupa007 Jan 5, 2013 @ 2:40pm 
Allright thanks for your help
Webby Jan 5, 2013 @ 3:28pm 
mines working with the 64bit fix im on windows 8 though
Chalupa007 Jan 5, 2013 @ 4:28pm 
This is really odd. I am at my grandparents and they have a stock computer. Intagrated card the game starts up no problem. I will hook up my old pc when I get home and give it a shoot. Maybe if it works I will jsut have to do a speed run through of the game
Chalupa007 Jan 5, 2013 @ 4:47pm 
@Etherouge are you using a intel CPU or a AMD CPU
Cloudsol Jan 5, 2013 @ 5:18pm 
AMD FX 6100 (six cores). I got the game to work, but Steam doesn't recognize it. Will not track game time or have the Steam overlay, if that matters to you. And since it matters to me, I might as well have pirated this damned game. The whole point of Steam is to easily download and play games. Oh well. I got it to work by following this video. But I had to rename the "Bin32" back to "Bin64" and manually launch "Crysis 64 Steam" or else it just didn't work.

http://www.youtube.com/watch?v=x8SbbnfqHVM

I don't even count this as a fix. ♥♥♥♥ this game.
Kopfgeldhamster Jan 5, 2013 @ 8:05pm 
Heres another fix that worked for me in several crashes. When starting Crysis try to run it in window mode (alt-enter). when the game shows the EA logo just hit alt-enter again.
My game crashed when changing the video settings. But if I do it in window mode, everythings fine. So perhaps this helps you.
Chalupa007 Jan 5, 2013 @ 8:50pm 
Alright just got it working! You need to download the 64 bit version folder. Than delte your bit 32 version after you do that rename your 64 bit version to the 32 name. The game opens the folder thinking its the 32 but compats it. I will keep ya updated if I crash a gain. Now time to play than tomorrow to fix Mass Effect 1
Showing 1-15 of 40 comments
< >
Per page: 15 30 50
Date Posted: Jan 5, 2013 @ 1:31pm
Posts: 40