Crysis > General Discussions > Topic Details
Pacmikey Oct 27, 2013 @ 3:06pm
Audio issues
At the beginning all voices sound robotic and distrorted. Is the game ment to be like this?
Showing 1-3 of 3 comments
< >
esuterik Oct 29, 2013 @ 4:55am 
hey man I bought crysis awhile ago but never installed it because I had been too busy with things... finally today I installed it and have had the same problem ... sent me crazy too as I went on google having a look around and all i could find were people with similar problems... search google for "crysis sound problem" you will see what I mean... I went through some of the peoples help on ways to get it to change but no luck at all... I found lowering the gameplay quality to the LOWEST setting made a big difference... so it came me to think.. this has nothing to do with audio and its a lag problem which is then affecting the sound. and yes I was right as my pc is very good. i7 3770k 32gb ram, gtx 650 2gb model... no problems at all... lowering the audio from 4800khz to 4400khz 16 bit no fix no need...

so i saw a guy just post about that most crysis wont start on 64bit but runs 32bit...

so i thought ok its def that reason its not using enough ram or whatever. some 32bit and 64bit issue... so i downloaded what he said and it fixed the problem instant...

McShave07 8 Sep, 2012 @ 11:15pm
Getting Crysis to run in 64-bit
O.k so here is the fix, grab the Bin64 file here, http://dl.dropbox.com/u/71527378/Bin64.zip

Unzip it and paste it into the following directory where you have steam installed Steam\steamapps\common\Crysis

In this folder, do the following.

Rename the Bin32 file to Bin32.bak
Now rename the Bin64 file you downloaded to Bin32

You can now running Crysis in 64-bit.

There should really be a sticky for this in the steam forums. It's disgraceful the amount of people that can't run this game. This fix doesn't seem to work for everyone, but it did for me.

Also http://steamcommunity.com/app/17300/discussions/0/864945309941708728/ if your game is crashing after changing the settings. Again not for everyone.

Hope this helps chaps.


cheers to McShave07 for your working fix!
Vanquish626 Nov 3, 2013 @ 6:04pm 
Originally posted by esuterik:
Getting Crysis to run in 64-bit
O.k so here is the fix, grab the Bin64 file here, http://dl.dropbox.com/u/71527378/Bin64.zip

Unzip it and paste it into the following directory where you have steam installed Steam\steamapps\common\Crysis

In this folder, do the following.

Rename the Bin32 file to Bin32.bak
Now rename the Bin64 file you downloaded to Bin32

This works! It fixed my sound issues and dramatically improved my FPS.

Thank you for pointing this out.

It is very sad that it is up to users to make a game work.
Pacmikey Nov 4, 2013 @ 3:55am 
Originally posted by esuterik:
hey man I bought crysis awhile ago but never installed it because I had been too busy with things... finally today I installed it and have had the same problem ... sent me crazy too as I went on google having a look around and all i could find were people with similar problems... search google for "crysis sound problem" you will see what I mean... I went through some of the peoples help on ways to get it to change but no luck at all... I found lowering the gameplay quality to the LOWEST setting made a big difference... so it came me to think.. this has nothing to do with audio and its a lag problem which is then affecting the sound. and yes I was right as my pc is very good. i7 3770k 32gb ram, gtx 650 2gb model... no problems at all... lowering the audio from 4800khz to 4400khz 16 bit no fix no need...

so i saw a guy just post about that most crysis wont start on 64bit but runs 32bit...

so i thought ok its def that reason its not using enough ram or whatever. some 32bit and 64bit issue... so i downloaded what he said and it fixed the problem instant...

McShave07 8 Sep, 2012 @ 11:15pm
Getting Crysis to run in 64-bit
O.k so here is the fix, grab the Bin64 file here, http://dl.dropbox.com/u/71527378/Bin64.zip

Unzip it and paste it into the following directory where you have steam installed Steam\steamapps\common\Crysis

In this folder, do the following.

Rename the Bin32 file to Bin32.bak
Now rename the Bin64 file you downloaded to Bin32

You can now running Crysis in 64-bit.

There should really be a sticky for this in the steam forums. It's disgraceful the amount of people that can't run this game. This fix doesn't seem to work for everyone, but it did for me.

Also http://steamcommunity.com/app/17300/discussions/0/864945309941708728/ if your game is crashing after changing the settings. Again not for everyone.

Hope this helps chaps.


cheers to McShave07 for your working fix!
It says no disc inserted.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Oct 27, 2013 @ 3:06pm
Posts: 3