Crysis > General Discussions > Topic Details
Darksource Mar 14, 2014 @ 4:35am
Low fps in Crysis
The game is awfully optimized, or either that it isn't optimized for Windows 7.
Showing 1-15 of 30 comments
< >
Kutya7701 Mar 14, 2014 @ 7:12am 
Post some system specs and your settings ?
Darksource Mar 14, 2014 @ 7:42am 
AMD Radeon HD 7870, AMD 6 core FX-6100, 8 gb ram, very high settings.
SonOfKonzan Mar 14, 2014 @ 7:42am 
Yeah, even though the is a 7 year old game it just is hard to run.

I still get 60 fps at all times with a gtx 650 and i5 cpu.
Darksource Mar 14, 2014 @ 7:52am 
I use to have the disk for it, and it ran well even with lower specs, but now I'm getting low fps.
Boomie Mar 14, 2014 @ 11:07am 
Verify your game cache, update your drivers, check if there's an unofficial / official patch, try capping your framerate at 60.
X(SpiralRider)X Mar 30, 2014 @ 4:07pm 
I have this game for origin, steam, and the original disc version. I've found that the only way I can run it perfectly smoothly with all the settings maxed on win 7 64 pro, 2 gtx 780 classifieds, i7 3820@4.3, and 32 gb 2133 quad channel mem is to run it in windowed mode. Otherwise it is like playing a slideshow. Pitiful. Every other game I have runs perfectly.

Edit: I found the fix. See my post farther down this thread for instructions.
Last edited by X(SpiralRider)X; Jul 4, 2014 @ 2:20pm
Darksource Apr 1, 2014 @ 2:29am 
Originally posted by X(SpiralRider)X:
I have this game for origin, steam, and the original disc version. I've found that the only way I can run it perfectly smoothly with all the settings maxed on win 7 64 pro, 2 gtx 780 classifieds, i7 3820@4.3, and 2133 quad channel mem is to run it in windowed mode. Otherwise it is like playing a slideshow. Pitiful. Every other game I have runs perfectly.
Thanks for the fix.
Plaid Apr 5, 2014 @ 6:34pm 
Originally posted by X(SpiralRider)X:
I have this game for origin, steam, and the original disc version. I've found that the only way I can run it perfectly smoothly with all the settings maxed on win 7 64 pro, 2 gtx 780 classifieds, i7 3820@4.3, and 2133 quad channel mem is to run it in windowed mode. Otherwise it is like playing a slideshow. Pitiful. Every other game I have runs perfectly.


Shoot man, I'd probably disable one of the cards for this game. It doesn't have a good history of running in SLI.
Daniel Potter Apr 15, 2014 @ 11:26am 
try running in windowed mode, it almost doubles my fps
Shade Apr 15, 2014 @ 7:15pm 
Is there anyway to get it in borderless window? I like the framerate, but that window bar puts me off.
Hippityd Apr 15, 2014 @ 9:47pm 
I ran this game np all the way to end on 660 gtx i5 3570k and then it got massively glitchy at end boss fight.
Boizaum Apr 17, 2014 @ 6:00pm 
boss fight is very glitchy..
Hippityd Apr 17, 2014 @ 8:28pm 
I also noticed if you mess with saving game on final boss you cannot lock on target with that gun.
Zedosk Apr 21, 2014 @ 12:38am 
Originally posted by davidjoyce72:
I ran this game np all the way to end on 660 gtx i5 3570k and then it got massively glitchy at end boss fight.
I ran it around 40-60 all the way and on the final boss the framerate dropped to ridiculous levels, around 10-15 FPS. The solution is to run the game using DirectX 9.
Hippityd Apr 21, 2014 @ 11:26am 
Loved the game otherwise =)
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: Mar 14, 2014 @ 4:35am
Posts: 30