A-hem...Not launching.
So, I'm "KINDA" a "VETERAN" player of Tribes.Was playing it "long" ago, and was addicted. Yet, a thing called Life and Computer Status, separated Tribes Ascend from me.
So I decided to check it out, heared it was dropped, but people still play it blah-blah-blah.

The Deal :
So, I downloaded the game from STEAM, launched it, (which launched the launcher (Ha ha.)), and as far as my memories recall, I should download a update. Checking For Sofrware updates, etc. etc. In the end, it shows me..

Picture Learn More About Tribes Gears - X
Video
Tribes Ascend 1.0.1268.1
The Bar (Its pitch black, nothing at all.) Play (Blackened, when I hover over nothing happens.)

Gears work, I tried it. Also, I checked the Tribes : Ascend site. It says SERVICE UNAVIABLE.
Does it mean there is something going on with Hi-Rez, or Tribes : Ascend is absolutely unplayable anymore?
Showing 1-6 of 6 comments
< >
ErecTim Apr 17 @ 2:52pm 
For me it says "waiting for download" and just stays there forever, with the blue bar full and the play button greyed out. Amazing.
RafUnforgiven Apr 30 @ 8:49am 
Originally posted by ErecTim:
For me it says "waiting for download" and just stays there forever, with the blue bar full and the play button greyed out. Amazing.

I got the same problem as this gentleman. Would anyone know a fix by any chance? I've tried switching the patch/installation directory to the steamapp folder, tried to reinstall etc.
SkullzMeister Apr 30 @ 11:19am 
I have the exact same problem, I've tried uninstalling, deleting all its files and re-downloading and it still refuses to go past "waiting for Dowwnload"
~]S.B[~ -Gamevoin (Jesus Jr.) Apr 30 @ 10:16pm 
Hello everyone,thats pretty strange, but on my side its gone long ago.The sites got back up, and the game works now.Probably was just a mainetance.I dunno about you, though...
Fairy Wogdog May 2 @ 1:26am 
I had this problem (the problem everyone but the OP has/had) but I solved it by completely uninstalling everything with the name tribes in it on my computer before reinstalling tribes ascend a following the instructions of this:
https://support.steampowered.com/kb_article.php?ref=5937-EYUH-5316
Whiplash May 6 @ 2:28pm 
I have the exact same issue. I used to play, got busy and fell out for awhile and when I tried to play again I get "waiting for download", black status screen and greyed out PLAY button. Uninstalled, reinstalled, nothing worked. Pretty frustrating. I'll give the link a try that Washington Irving provided. Hope it works.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50