Ricky Spanish Feb 27, 2014 @ 1:57am
running in windows mode, but as soon as game starts i hit 8 frames a second, suggestions?
AMD athlon II x4
8gb 1866
gtx 660 3gb
Showing 1-7 of 7 comments
< >
jorenthecole Mar 2, 2014 @ 3:09am 
hmmm...counter-question: how many ships did you enable for maximum ships allowed? perhaps but video memory in 'safe" mode, from launcher ; how many neutral and normal enemy empires did you select?....these may not have any impact on actual gameplay, but may slow down either your processor or some thread or another.... - let me know, as I'm sure you'll be able to play :)
Thunderbuddy - #Nemo Mar 2, 2014 @ 12:01pm 
It's a long known problem with the direct-x emulation.

I know people, who play it without any problems under Windows 7 64bit and there are people like you and me, which have enough CPU/RAM/GPU to play Battlefield 4 but the fps drop to 10 or less. (Especially, when opening a menu)

I've tried out many "solutions" and things, to get it running. But in the end, all that helped for me, was to install Windows XP and Windows 7 on the same PC and if I want to play Space Emipres V, Need for Speed Underground 2 or any other older game, I have to reboot the PC, choose Windows XP and it all works like a charme...
Telfram Mar 3, 2014 @ 4:31am 
What res are you running the game at, i've had the retail version since release and the biggest slow downs were caused by too many ships and/or a high res seleted.
Ricky Spanish Mar 3, 2014 @ 9:27am 
Originally posted by Telfram:
What res are you running the game at, i've had the retail version since release and the biggest slow downs were caused by too many ships and/or a high res seleted.
1440x900
Telfram Mar 3, 2014 @ 12:32pm 
Try using a lower res and set graphic options to low, if that works it's just fine tuning to see what works best on your system.
Ricky Spanish Mar 3, 2014 @ 1:53pm 
Originally posted by Telfram:
Try using a lower res and set graphic options to low, if that works it's just fine tuning to see what works best on your system.
running 1024x768x16. getting 11 FPS. on a card that can get 40 in bf4 on high settnigs
Telfram Mar 4, 2014 @ 5:02am 
Does seen a wee bit low, have you got latest video drivers or tried changing the 'video device' as you have 'RGB Emulation', 'Direct3D HAL' and 'Direct3D TL HAL'.
Past that, i'm afraid i'm out of ideas for the slow down.
P.S. Any differance running in full screen?
Last edited by Telfram; Mar 4, 2014 @ 5:03am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50