Luxor 3 > General Discussions > Topic Details
Unbekannter Mar 18, 2014 @ 8:33pm
"Preparing to launch Luxor 3..."
I keep seeing this over and over, in some kind of irritating loop. Just bought it, so I've not even been able to launch it once. Loved this game, some time ago, so it would be nice to get it up and running.

If anyone has any solutions or suggestions, please let me know.

EDIT:

Solved. Seems you have to enable the beta update in order to play it. 'o.O Bit odd, but OK.
Last edited by Unbekannter; Mar 18, 2014 @ 8:43pm
Showing 1-6 of 6 comments
< >
Wolf Lohuis Mar 23, 2014 @ 3:18pm 
Thanks, got this problem too. You helped me out :)
Unbekannter Mar 23, 2014 @ 6:06pm 
Originally posted by Wolf Lohuis:
Thanks, got this problem too. You helped me out :)

[: That's why I left it and added a solution; I hoped it would help others.
GamerByDay  [developer] Mar 25, 2014 @ 2:28pm 
Should be fixed now. Sorry for the delay!
Wolf Lohuis Mar 25, 2014 @ 2:51pm 
Originally posted by GamerByDay:
Should be fixed now. Sorry for the delay!

Thanks a lot for the fix and the heads up!
Unbekannter Mar 25, 2014 @ 7:19pm 
Originally posted by GamerByDay:
Should be fixed now. Sorry for the delay!

Thanks for the fix, guys.
Spyd3r666tm May 1 @ 2:02pm 
Originally posted by GamerByDay:
Should be fixed now. Sorry for the delay!
No Picture for me only sound I tried beta fix and installing to another partition still nothing's happening reinstalled countless times still nothing please help, i doubt there is no way to get my hard earned money back albeit it was only a fiver but still, Why sell the games if they dont work
Showing 1-6 of 6 comments
< >
Per page: 15 30 50