Luxor 2 > General Discussions > Topic Details
c-***** Dec 2, 2012 @ 10:51pm
Will not start from steam nor from local icon
The error dialog is below. The other user's idea of spamming it to start it makes no sense without a complete description of what he means.

I'm on Win7 Home Premium.

Thanks for any ideas.
-------------------------------------------------


Application Error

This application requires "Windows 98 SE" or later
to execut. Please ensure that the minimu software
and hardware requirements are met, before attempting
to run this applicaiton again. The application will
terminate now.

[OK]
Showing 1-4 of 4 comments
< >
Τhe Rolling Cheese Wheel Dec 29, 2012 @ 7:11pm 
Highlight luxor 2 in the steam library. Spam enter until the game launches. Then again I don't get the error you have,
Wolfshour Mar 23, 2013 @ 3:28pm 
When you enable the compatibility mode it should run under Windows 7 64bit. To enable right click on the "Luxor2.exe" in the Luxor 2 installation folder in the steam library e.g. "C:\SteamLibrary\SteamApps\common\Luxor 2". Choose "Windows XP SP3".
Maybe you have to copy the steam.dll from the Steam installation directory (e.g. "C:\Program Files (x86)\Steam") to the same folder where the Luxor2.exe is.
SimpleLuck Mar 24, 2013 @ 1:56am 
Thanks wolfshour, that worked for me.
blarth Jan 26, 2014 @ 10:35pm 
Running in compatibility mode for windows vista also works. If I try compatibility mode for xp, I get the steam.dll error (which wolfshour explains how to get around). Setting compatibility mode to windows vista required nothing else, it just worked.
I am running windows 7 professional.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50