Ban the Bums 30 okt 2012 om 8:20nm
Frame issues.
I have a pretty decent PC, I can run every 'modern' game at highest settings; but jeez is Stranger's Wrath destroying my cards. Is it poorly optimized or is something wrong here?
1-15 van 26 reacties weergegeven
< >
Kizami z3r0 21 nov 2012 om 1:07nm 
Damn and here i thought i was the only one. I'm running with an ATI HD5770 Normally it runs everything pretty damn well. Say for higher end games such as crisis. or BF3 But yeah i have to agree this game is tanking something awful on my Rig.
gpw11 8 dec 2012 om 11:51nm 
I'm pretty sure this is an ATI thing. I also have a 5770 and have the same problem (to the point that it's unplayable). Sadly, I don't expect it's going to be fixed.
Ban the Bums 9 dec 2012 om 6:06nm 
Odd. All 3 of us have 5770s. How unfortunate.
√itamin ∃✘ 27 feb 2013 om 12:26vm 
That makes 4 of us :)

I also have a 5770 and I was getting 10 fps untill I read that it's a problem with ATI cards and not to use AA so I turned AA off and the fps is now normal. Now I get periodic freezing every 30 seconds to a minute and when it freezes the game will be frozen for around 10 seconds.

I can't believe they would go through the trouble of making an HD version and release a bug fix patch but they wont do anything about the propblem with the bugs for those with an ATI card.

I also wish the game had a 1366x768 option.
DPB 2 mrt 2013 om 4:21nm 
Can I join the club? I'm another with a 5770 (well, a 6770 but it's the same card rebranded), and the game constantly freezes, and it actually seems to have got worse with recent driver updates.

It's nice that they gave us the graphical upgrade for free, but couldn't they have made it optional if it was going to have such glaring compatibility issues. The non-HD version had some graphical glitches on AMD cards, but at least it was playable.
Zahitos 13 jun 2013 om 7:12nm 
i have a 7870. Same problem :/
Lord Maximus 15 jun 2013 om 11:37vm 
I have a GTX680.... same issue
Dr. Zaius 13 jul 2013 om 7:07nm 
5870 here, It doesn't get above 10 frames, and switching to first person view means getting 1 frame every 2 seconds
DYMAXION 16 jul 2013 om 9:11nm 
No frame drops with a 570 at 2560x1440.
DYMAXION 16 jul 2013 om 9:12nm 
But my cpu is at 4.3ghz.
dave 16 jul 2013 om 9:13nm 
ATI card, tried updating catalyst control centre and drivers based on another post here and that turned it from very laggy to playable, but it's still nowhere near what I'd expect on a modern machine. Big let down.
DYMAXION 16 jul 2013 om 9:18nm 
Try disabling in game aa and vsync.
Nominative99 16 jul 2013 om 9:27nm 
I got a 5770 as well. Game is pretty much unplayable in any setting. Shame it will never get fixed.
dave 17 jul 2013 om 1:23vm 
Messing around with the settings doesn't seem to accomplish much. Think it's just a really bad port, which is a real shame.
DYMAXION 17 jul 2013 om 1:14nm 
The non-hd version is included with the gog version if that helps.
1-15 van 26 reacties weergegeven
< >
Per pagina: 15 30 50