Oddworld: Stranger's Wrath HD > Общи дискусии > Подробности за темата
Ban the Bums 30 октомври 2012 в 8:20 следобед
Frame issues.
I have a pretty decent PC, I can run every 'modern' game at highest settings; but jeez is Stranger's Wrath destroying my cards. Is it poorly optimized or is something wrong here?
Показване на 1-15 от 26 коментара
< >
Kizami z3r0 21 ноември 2012 в 1:07 следобед 
Damn and here i thought i was the only one. I'm running with an ATI HD5770 Normally it runs everything pretty damn well. Say for higher end games such as crisis. or BF3 But yeah i have to agree this game is tanking something awful on my Rig.
gpw11 8 декември 2012 в 11:51 следобед 
I'm pretty sure this is an ATI thing. I also have a 5770 and have the same problem (to the point that it's unplayable). Sadly, I don't expect it's going to be fixed.
Ban the Bums 9 декември 2012 в 6:06 следобед 
Odd. All 3 of us have 5770s. How unfortunate.
√itamin ∃✘ 27 февруари 2013 в 12:26 сутринта 
That makes 4 of us :)

I also have a 5770 and I was getting 10 fps untill I read that it's a problem with ATI cards and not to use AA so I turned AA off and the fps is now normal. Now I get periodic freezing every 30 seconds to a minute and when it freezes the game will be frozen for around 10 seconds.

I can't believe they would go through the trouble of making an HD version and release a bug fix patch but they wont do anything about the propblem with the bugs for those with an ATI card.

I also wish the game had a 1366x768 option.
DPB 2 март 2013 в 4:21 следобед 
Can I join the club? I'm another with a 5770 (well, a 6770 but it's the same card rebranded), and the game constantly freezes, and it actually seems to have got worse with recent driver updates.

It's nice that they gave us the graphical upgrade for free, but couldn't they have made it optional if it was going to have such glaring compatibility issues. The non-HD version had some graphical glitches on AMD cards, but at least it was playable.
Zahitos 13 юни 2013 в 7:12 следобед 
i have a 7870. Same problem :/
Lord Maximus 15 юни 2013 в 11:37 сутринта 
I have a GTX680.... same issue
Giuseppe 13 юли 2013 в 7:07 следобед 
5870 here, It doesn't get above 10 frames, and switching to first person view means getting 1 frame every 2 seconds
DYMAXION 16 юли 2013 в 9:11 следобед 
No frame drops with a 570 at 2560x1440.
DYMAXION 16 юли 2013 в 9:12 следобед 
But my cpu is at 4.3ghz.
The Dank Knight 16 юли 2013 в 9:13 следобед 
ATI card, tried updating catalyst control centre and drivers based on another post here and that turned it from very laggy to playable, but it's still nowhere near what I'd expect on a modern machine. Big let down.
DYMAXION 16 юли 2013 в 9:18 следобед 
Try disabling in game aa and vsync.
Nominative99 16 юли 2013 в 9:27 следобед 
I got a 5770 as well. Game is pretty much unplayable in any setting. Shame it will never get fixed.
The Dank Knight 17 юли 2013 в 1:23 сутринта 
Messing around with the settings doesn't seem to accomplish much. Think it's just a really bad port, which is a real shame.
DYMAXION 17 юли 2013 в 1:14 следобед 
The non-hd version is included with the gog version if that helps.
Показване на 1-15 от 26 коментара
< >
На страница: 15 30 50