DannyJay Sep 14, 2012 @ 7:34am
Intense Lag and Freezing while attempting to playing.
When I get into the actual gameplay, its freezing constantly, then unfreezing for a split second before freezing again.
The sound continues to play while the game is froze too.
I've tried running the game at different resolutions (It even does it at 640X480 Windowed), playing in a window, turning off V-Sync, completely disabling Anti-Aliasing, but still everytime it has great amounts of freezing and lag that just makes the game unplayable.
I'm pretty sure its not a problem with my PC, since I can run Skyrim at high settings and at 1920X1080 fullscreen.


Anyone else having this problem?
Showing 1-15 of 40 comments
< >
Stewart Gilray  [developer] Sep 14, 2012 @ 7:35am 
This is something we're aware, and there is mention of it in the Readme file, which will give you instructions on how to avoid it :)
DannyJay Sep 14, 2012 @ 7:45am 
Alright, I've reduced the bits-per-pixils to 24, and the games much less laggy and now playable, but its still freezing, not as regular as it did before, but freezing for a couple of seconds here and there.
RaMi SaN X Sep 14, 2012 @ 7:54am 
Me too me,, LAGGY very LAGGY,,Me the same played Skrim high setting and was good to play but now,,cant,,need help
RaMi SaN X Sep 14, 2012 @ 8:07am 
Originally posted by DanielAllen12:
Alright, I've reduced the bits-per-pixils to 24, and the games much less laggy and now playable, but its still freezing, not as regular as it did before, but freezing for a couple of seconds here and there.
Can you tell me how did you do that?? cant find the option to reduce " Pixils "
Stewart Gilray  [developer] Sep 14, 2012 @ 8:19am 
Did you read the readme file?
thebmxeur Sep 14, 2012 @ 8:20am 
I've got the same problem. I "fixed" it by setting steam process priority to low in the task manager an than launch the game.
I think it's a common problem with core 2 duo processor. I had that with Rage, L.A. noire and other game. Those games ( Rage and L.A. noire ) fixed the problem by forcing the game to use only one thread.
If Stewart can make someone look at that at Jaw it would be great.

Config : core 2 duo e8500, ati radeon hd4850, asus mother board, 10 Go of ram.

I don't know if it due to that manipulation, but when I quit the game the process is still running and use 50% of the cpu ( 1 core ).
DannyJay Sep 14, 2012 @ 8:29am 
I just tried setting Steam to 'low' priority, the game still runs as badly as it did before.
I'm starting to think this is a problem with the game, not my system.
Cosmic Sandwich Sep 14, 2012 @ 8:40am 
turning off vsync fixed any stuttering I had
RaMi SaN X Sep 14, 2012 @ 8:48am 
Yes I read allready " Read me " but I dont know,how what I should write,,,
DannyJay Sep 14, 2012 @ 8:48am 
I've had V-Sync turned off from the very start.
I never have it on in any game.
Its not stuttering, either, its the screen freezing on a single image for a couple of seconds, working for a split second, then freezing again while the sound continues to play.
I've tried almost everything now, from changing settings in the configuration to setting the game to compatibility mode, nothing seems to work, so I do think it is a problem with the game and some kind of incompatibility or something, since my computer can run Skyrim, Fallout 3/NV and many other games on High at 1980X1080 with little to no lag.
RaMi SaN X Sep 14, 2012 @ 8:50am 
Enter the launch options you wish to apply (be sure to separate each code with a space) and click OK. WHAT I should write? " The Read me text " I dont understand it,,
Talon09 Sep 14, 2012 @ 9:05am 
Vsync off, bpp to 24 , antial off and its still lagging and freezing...what a mess!
DannyJay Sep 14, 2012 @ 9:13am 
I have the utmost faith that JAW will patch this with some sort of fix or something.
Until then, this is unfortunately unplayable. :(

Shame too, I've been following these Oddworld HD releases for over a year now, and was looking forward to playing Strangers Wrath in HD.
DannyJay Sep 14, 2012 @ 9:31am 
I just read in another discussion that JAW are working on a hotfix for the performance issues.
Thats a relief.
thebmxeur Sep 14, 2012 @ 9:38am 
Have you try to desable Steam overlay ?
Showing 1-15 of 40 comments
< >
Per page: 15 30 50