Oddworld: Stranger's Wrath HD

Oddworld: Stranger's Wrath HD

Statistieken weergeven:
13 sep 2012 om 6:46nm
"Game Application has stopped working"
Hello there.

I was very excited to see the Stranger's Wrath HD update come to Steam, but I seem to have a problem. Every time I try to play the game, I get to the logo screen and a window pops up stating that "A problem has caused the game application to stop working". This is incredibly vague and incredibly frustrating, so I was wondering if anyone might be having a similar issue, or ideally knew how to overcome said issue.

I'd really appreciate any help I could get on this, I can't wait to finally play this game again.
Laatst bewerkt door ; 13 sep 2012 om 6:46nm
< >
1-15 van 163 reacties weergegeven
Sgt. Tiki 13 sep 2012 om 8:15nm 
This is happening to me too, so I'd like to know if anybody finds a fix.
The Fettman13 13 sep 2012 om 8:27nm 
I haven't gotten an error message, but I get to the main menu (I can tell from memory just because of the sound effects) and I'm stuck at a black screen.
Commander Boreale 13 sep 2012 om 9:09nm 
I've got this problem too. :L
Big K 13 sep 2012 om 10:11nm 
I have the same problem, but I'm able to get to the main menu. When I start a new game it goes through the intro video then crashes at the loading screen.
paing67 14 sep 2012 om 4:12vm 
Same here. But it's not new for me. I have the same problem with the old version !!
With Windows 7 x64 and a Radeon 6970. Anybody can help ?
Yellow Dog 14 sep 2012 om 4:50vm 
Same problem here. It's worked in the past, though I haven't tried the game in a while. Windows 7 x64, Radeon 6960, AMD Phenom II X4 965 processor. Not sure if any other info would be useful.
Komus 14 sep 2012 om 5:14vm 
Same here. Main menu -> Intro cinematic -> Error, stopped working.
Windows 7 x64, ATI Radeon Mobility HD 5850, Intel Core i5 430M (2,26 GHz)
Fostus 14 sep 2012 om 6:03vm 
Same here... Windows 7 x64 ATI Radeon HD 6950.
Either it's Win 7 x64 version that causes issue, or it's ATI...
Laatst bewerkt door Fostus; 14 sep 2012 om 6:03vm
Stewart Gilray  [ontwikkelaar] 14 sep 2012 om 7:29vm 
We are aware of an issue that MAY affect some people, we're looking to fix this tonight in a small hotfix later today, cheers for the patience :)
14 sep 2012 om 10:49vm 
Wow, I never expected Stewart Gilray himself would comment on this, that's pretty awesome! I don't know if I'll get this opportunity again so I'd like to take it to say thank you to you and the others at JAW for reviving such a fantastic game series.

Anyway, thank you for responding so quickly to this issue, it's really nice to see that you guys actually see and read the community responses. :)
paing67 14 sep 2012 om 11:09vm 
Yeah, very quick response So we wait for the hotfix. I'm very impatient to play !
Sgt. Tiki 14 sep 2012 om 9:50nm 
So, did that hotfix that apparently happened today fix this? It still won't work for me.

Kudos to JAW for jumping on it so quickly regardless.
Skeletalcrows 14 sep 2012 om 10:48nm 
Very sad that I can't play this game, my computer is more than able to play it. If I try to launch from the exe file it just black screens even after disabling desktop effects. I get the launcher when I try to start from steam client, but as soon as the loading page starts, instantly I get an appcrash error and it closes.
paing67 15 sep 2012 om 3:22vm 
Still not working too.I lanch the game, a brief black screen and then "Game Application has stopped working"....
Leviathan 15 sep 2012 om 3:52vm 
I had a similar problem but I solved it updating my graphic card's driver
< >
1-15 van 163 reacties weergegeven
Per pagina: 15 30 50