Mr. Stretch Jul 29, 2014 @ 9:53am
Game crashes on start
After the Oddworld Inhabitants splash screen, it crashes. "Game Application has stopped working". I've tried everything. I have an integrated Intel card, but I should still be able to play. I can play most NEW games at medium settings and a lower resolution with no problem. And this is a 9 year old game, so don't go saying that "My PC's not powerful enough" tripe, because my PC should destroy this game. I'll just post my specs.
Manufacturer: Dell
Model: Inspiron ONE2320
Processor: Intel(R) Pentium(R) CPU G630 @ 2.70GHz
2.70 GHz
RAM: 4.00 GB
System type: 64-bit Operating System (Windows 7)
If my PC really can't run this 9 YEAR OLD game, then this port is utter trash.
Last edited by Mr. Stretch; Aug 7, 2014 @ 12:39pm
Showing 1-3 of 3 comments
< >
EQSguy Aug 4, 2014 @ 2:54am 
my computer has similar specs to yours and it worked fine on my computer, but recently i updated my computer to windows 8.1 and now i'm getting the same problem as you
Mr. Stretch Aug 5, 2014 @ 10:25am 
I may try this on my laptop, to see if it works there. If it does, then that confuses me even more. I'm gonna go do that.
WinterVision Aug 6, 2014 @ 8:08pm 
I'm running Intel core i3 with windows 7 home premium and I have the same problem.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50