MineCon28 Mar 16 @ 7:57am
Problem with Warhammer 40k dawn of war 2
My warhammer isnt working i downloaded it and it wont opened i havnt play it at all. I bought the dlc first and the the full game and i wont work does anyone any salutions?
Showing 1-11 of 11 comments
< >
MineCon28 Mar 16 @ 8:00am 
But all my other games work fine.
jumpers999 Mar 16 @ 5:48pm 
Did you try installing windows for live. Try installing that and also try validating the game files by right clicking on warhammer, go to properties, local files and verify integrity of files

Galahad Mar 16 @ 8:45pm 
I have the same issue. I have also downloaded and installed the latest version of Games for Windows Live Marketplace and logged into my gatertag that i used to use for playing DOW2. I have all 3 DOW 2 titles and only Retribution will work.
All files succesfully validated for both DOW2 and Chaos Rising.

Steam needs to get onto this and remove the old Live DRM that is stopping so many people from playing games that they bought.
Coldsteel Mar 17 @ 2:30am 
What version of Windows are you using? I had serious issues with windows 8, but got it to work fine on my windows 7 machine.. You may wanna remove your data files, and redownload and install. Also, it could be an issue with your firewall. You may wanna turn if off for a few minutes while getting it to start. Norton stopped mine from comunicating with the MS live server. If you have windows 8, there is a work around for that too, but didn't bother with it cause I got it working on my windows 7 computer. Hope that helps...I hope you get yours working soon as possible, Microsoft is shutting down it's live servers, and that will render it unplayable unless valve gives us another way to play on steam.
fildenegnet Mar 20 @ 11:25am 
hey guys! how to play with somebody here?
Voidwarp Mar 24 @ 12:43pm 
mine doesnt work aswell
heavyturtle1234 Mar 26 @ 4:40pm 
mine wont work, when i try to open it it says "preforming first time setup (1 of 2)" for a split second then dissapears.
Svampfest Mar 27 @ 9:49am 
Hey Im having the same problem and im using windows 8. I have tried everything including redownloading and least two or three times, firewall is turned off and i have even tried the validation. When ever I try to launch it i come up with an error that says that dow2.exe ordinal can not be found. I cant find anything online that helps and everything i have found and done has not helped in the slightest.

Originally posted by heavyturtle1234:
mine wont work, when i try to open it it says "preforming first time setup (1 of 2)" for a split second then dissapears.

Mine started out like this and i did a couple fixes that i found on line and it got me to the dow2.exe not found.
Svampfest Mar 27 @ 10:11am 
sorry for the double post but i found out how to fix the problem go to this website http://www.xbox.com/en-US/LIVE/PC/DownloadClient
and download this client and the game will run. now i have came across another problem with that no graphics just subtitles in the open cinematics and also im playing chaos rising not dow 2..... but at least you can get into the games now. Hope i helped!
MineCon28 Apr 2 @ 7:50am 
it says i need a xlive.dll file
Coldsteel Apr 8 @ 4:13pm 
Mine did that too, you must be using windows 8
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Mar 16 @ 7:57am
Posts: 11