Harvest: Massive Encounter

Harvest: Massive Encounter

View Stats:
Arpegius Feb 15, 2013 @ 5:54pm
Ubuntu 12.04 64bit - game working
The problem is with startup script, wich probably was some old dirty fix for beta steam version.
Edit this file (run in console):
gedit ~/.local/share/Steam/SteamApps/common/Harvest\ Massive\ Encounter/run_harvest
and leave only this two lines:

exec ./Harvest

If someone is wonder where are those missing libraries here is my ldd log[pastebin.com].
< >
Showing 1-15 of 15 comments
HamstahGuru Feb 16, 2013 @ 2:08am 
Thanks for the fix, the file was in ~/Steam/... instead of ~/.local/share/Steam/... for me

Pesch Feb 16, 2013 @ 2:23am 
It did the trick! Thanks!
OvermindDL1 Mar 1, 2013 @ 1:53am 
I was never able to get it to run in Steam either but gave up long ago to play other things, came back to it, still not working, same issue, fixed it so came here to say their script is wrong and apparently it is well known and still not fixed... Do they plan to fix this?
Nod Mar 4, 2013 @ 1:24am 
The problem in that script is where he is using dirname to populate the $INSTDIR variable. $0 needs to be quoted because there are spaces in the path:

INSTDIR=`dirname "$0"`;

works and it can now find the executable. My next problem is missing libjpeg62
Nod Mar 4, 2013 @ 1:44am 
So the execute script checks if libjpeg62 is installed on my system it finds it, so it executes the game, the game then looks for the ia32 version of the lib which isnt there so it crashes with a loading shared libraries error ... looks like this stuff was never tested on a 64 bit system which is pretty dumb given thats what most linux users are running ...

The executable wants an ia32 version of libjpeg32. The ia32-libs package does not install this so you need to do it manualy like this:

$ sudo apt-get install libjpeg62:i386

It also does not find the version in ~/.local/share/steam.

This is all on 12.04 64bit.
Nod Mar 4, 2013 @ 2:00am 
Gahh, now its missing more ia32 stuff libCgGL ... cant be bothered working out what package to install, i just changed the LD_LIBRARY_PATH in the script to point at the .local/share/Steam stuff. That script is a mess, they really should test this stuff properly.

Game works now, hope it was worth it :)
Nod Mar 4, 2013 @ 11:10pm 
grr, was working yesterday, now it starts a process but no gui :(
Files Mar 5, 2013 @ 10:12pm 
I think I did this too. Has been working for a while.
Arpegius Mar 6, 2013 @ 4:49pm 
Guys, Orly?
See what steam put inside your enviroment, when running your game. it's all you need to run, so all the script is useless. (May be you need to update steam)
Most of this libraries can be found inside steam dirs.
You also cannot run this game without steam, so your work is useless.

Also you making a mess, or you want just to troll...
Nod Mar 7, 2013 @ 3:12am 
Um, speaking of trolling I'm not sure wtf you're on about. All my observattions about the script are 100% factual. If you fix the dirname bug I point out the script runs and excecutes the game provided you have the correct ia32 libs installed or you point the LD_LIBRARY_PATH at the right local steam location. The script assumes you are running a 32bit os like I said, it uses dpkg to check for the libs which will find 32 or 64 bit versions but when the Harvest exceutable runs it assumes the 32bit ones.

The game now runs fine for me but sometimes fails to bring up a screen and sometimes gets stuck on a black screen on load, doing 'pkill Harvest' and starting again fixes that.
Foobar Sep 17, 2013 @ 1:00pm 
Got it running by cutting down run_harvest as suggested by OP but game is so unstable that I can't enter my players name with a capital letter.
hey devs: get back to work. Ubuntu 64bit isn't uncommon these days...
Last edited by Foobar; Sep 17, 2013 @ 1:01pm
imp_boy_2003 Jan 6, 2014 @ 8:48am 
perfect thanks
Peter Dec 17, 2014 @ 1:43am 
I used https://www.debian.org/distrib/packages#search_contents to find missing packages.

Now I am battling:
ERROR: ld.so: object '~/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: ~/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Daisy version 0.7No running copy of Steam detected. This version of Harvest: Massive Encounter requires Steam.Game removed: AppID 15400 "Harvest: Massive Encounter", ProcID 10586

I tried:
export LD_LIBRARY_PATH=${INSTDIR}/bin:~/.steam/bin32:~/.steam/bin64

And I also tried:
export LD_LIBRARY_PATH=${INSTDIR}/bin:~/.steam/bin64:~/.steam/bin32

Well... and then I decided to change the script the OP suggested... and the game launched.
[LINUX] Seven Oct 22, 2015 @ 2:48pm 
just stop supporting devs who leave their games broken and unfixed for years, just saying
nonadvanced Dec 8, 2015 @ 8:06pm 
Still broken as of 12/15 in Fedora.
< >
Showing 1-15 of 15 comments
Per page: 15 30 50