Mad Dan Eccles Dec 24, 2012 @ 2:14am
Read if you're having technical problems
Check the BG&E forum[www.gog.com] on GOG for solutions to most problems.

I can tell you that one major cause of graphical glitches nowadays in BG&E is multi-core processors. Load the game, tab out and open task manager. Set BGE.exe (or whatever the steam version is named) to one core. You'll have to do this every time you play the game.

There is a program called Imagecfg, which can be used to permanently patch an executable to use one core, but you'll have to search for it and how to use it. It used to be distributed with official Microsoft Server Resource Kits. I've only used it with my disc version of the game, and it worked fine. Of course, virus scan anything you download, check against checksums from independent sources, and even then take caution. Note that if you verify the game cache, it will probably overwrite the changes made to the executable.

I can't remember if I also forced Vsync in my video card control panel; it's been a year since I played. In any case, it's probably a good idea, as the game doesn't limit framerate, which could make your graphics card run too hot.
Last edited by Mad Dan Eccles; Dec 24, 2012 @ 2:20am
Showing 1-15 of 17 comments
< >
Unluckystudent Dec 29, 2012 @ 2:58pm 
This worked for me!! Thank you! Running windows 7 x64 on an AMD Athlon X2.
Yshzark Jan 19, 2013 @ 12:10am 
I still can't run the game. It always says:"Beyond Good & Evil hasn't been installed in a correct way. PLease install Beyond Good & Evil." Erm...I reinstalled it about 5 times but it didn't help, and I also tried it with on CPU, but didn't work neither. So, if anyone knows what's the problem or how to run it on vista anyway, please help me. ;)
Codruji Mar 20, 2013 @ 4:40am 
This doesn't help me at all. Everytime I tried this, it says "access denied". Help?
Zeldabro Jun 5, 2013 @ 7:38pm 
Hi. So I am having a problem that seems way simpler than it should. I am playing the GOG version of the game, and it wont let me alt+tab. If I ctrl+alt+dlt, the resolution screws up. Any reason why this is?
Bloodwrath Jun 5, 2013 @ 10:59pm 
Works great! Thanks
Spycheck Me Jun 15, 2013 @ 7:20pm 
Originally posted by Mad Dan Eccles:
Check the BG&E forum[www.gog.com] on GOG for solutions to most problems.

I can tell you that one major cause of graphical glitches nowadays in BG&E is multi-core processors. Load the game, tab out and open task manager. Set BGE.exe (or whatever the steam version is named) to one core. You'll have to do this every time you play the game.

There is a program called Imagecfg, which can be used to permanently patch an executable to use one core, but you'll have to search for it and how to use it. It used to be distributed with official Microsoft Server Resource Kits. I've only used it with my disc version of the game, and it worked fine. Of course, virus scan anything you download, check against checksums from independent sources, and even then take caution. Note that if you verify the game cache, it will probably overwrite the changes made to the executable.

I can't remember if I also forced Vsync in my video card control panel; it's been a year since I played. In any case, it's probably a good idea, as the game doesn't limit framerate, which could make your graphics card run too hot.

Where is the option to make it use one core? I am experiencing glitchy textures and menu icons, and a slow framerate whenever fog/similar effects are used.
Zeldabro Jun 19, 2013 @ 4:53pm 
Hi all.

I found an excellent guide to setting up BGE for modern PC's: http://wordpress.fusetnt.com/2009/06/making-old-games-in-steam-not-suck-part-1-beyond-good-and-evil/

This guide shows that the problems with this port seem to go a little beyond multicore processing. I will try this out soon.
[ST] SpindalTop Jul 6, 2013 @ 4:50pm 
Hmmm I'll have to try the core change.
Z3r0Fear Jul 12, 2013 @ 4:55pm 
Oh great another game I wanted to buy that is filled with a game breaking bug...
Zeldabro Jul 12, 2013 @ 5:47pm 
Originally posted by Z3r0Fear:
Oh great another game I wanted to buy that is filled with a game breaking bug...

If you dont mind gaming with a keyboard/mouse, read the guide that I posted earlier and it should be good to go.
errdog Sep 28, 2013 @ 5:35am 
My biggest problem was solved by changing two things in the setup config program. Advanced tab - uncheck HW Vertex processing, multi vertex stream, and W buffer
Red Baron Oct 1, 2013 @ 11:35pm 
This is all great info. Thanks a ton!
Button Pushed Nov 8, 2013 @ 5:00pm 
Originally posted by Zeldabro:
Hi all.

I found an excellent guide to setting up BGE for modern PC's: http://wordpress.fusetnt.com/2009/06/making-old-games-in-steam-not-suck-part-1-beyond-good-and-evil/

This guide shows that the problems with this port seem to go a little beyond multicore processing. I will try this out soon.
This also works on boxed copies of the game, nice being able to play it again without all the flickering shadows. :) Guess I have my excuse for re-buying a backup copy on here now :D
ChkDsk Feb 21 @ 11:19am 
Originally posted by errdog:
My biggest problem was solved by changing two things in the setup config program. Advanced tab - uncheck HW Vertex processing, multi vertex stream, and W buffer
Perfect!
Lance Feb 21 @ 6:43pm 
I use a multi core pc and this was all that was needed to get the game running flawlessly

Originally posted by French Kill:
Originally posted by errdog:
My biggest problem was solved by changing two things in the setup config program. Advanced tab - uncheck HW Vertex processing, multi vertex stream, and W buffer
Perfect!
Showing 1-15 of 17 comments
< >
Per page: 15 30 50