Darwinia > Allgemeine Diskussionen > Themendetails
fratti 16. Feb. 2013 um 11:36 Uhr
Problems with too fast mouse on Linux with a touchpad? Check here!
Okay, first of all, this is a bug/weirdness in SDL on Linux. After some research and trial and error I've found some nice workarounds for this.
What I've successfully tried is the following: Edit your .bashrc, add the following line:
export SDL_VIDEO_X11_DGAMOUSE=0
Then do
source ~/.bashrc
to reload it, and run the game through the same bash prompt.
A solution I haven't tested yet would be editing the run_steam.sh to use SDL_VIDEO_X11_DGAMOUSE=0 ./darwinia.bin.x86 instead of setting the system variable through the bashrc.

All in all the game is a very good linux port by the way. Worked on arch like a charm after this slight modification.