Darwinia > General Discussions > Topic Details
Dax Feb 19 @ 10:49am
Fatal Error!
So the games been working fine for now. A new steam update comes along and I am now presented with:


ERROR : 'Error initialising Steam:
Wrapper not implemented
Last error: The system cannot find the path specified.
(3)'

Tried looking online for solutions and can't seem to find one that works. Have attempted to make a copy or shortcut to the steam.dll within the darwinia directory, I have reinstalled the game multiple times, deleted steam.dll and restarted steam to no avail.

Other games seem to work fine so I assume its Darwinia didn't like the latest steam update! If anyone has the same problem and has cracked it would be nice of you to share :)
Showing 1-15 of 26 comments
< >
SciStarborne Feb 19 @ 2:28pm 
I'm also getting this. It worked fine yesterday, not at all today. Turning off the steam overlay doesn't help. Copying the steam.dll to the game folder doesn't help.

Darwinia's blackbox.txt report says;

VERSION : win32-full-steam-1.5.10
ERROR : 'Error initialising Steam:
Wrapper not implemented
Last error: The system cannot find the path specified.

(3)'

Same wether you try to start it from within Steam or by running the file directly.
Iceman Feb 19 @ 5:05pm 
I'm getting the same eror.
dmdisab Feb 20 @ 2:00pm 
I am also getting the same error after the latest update to Steam.
G3000 Feb 20 @ 11:22pm 
Yeah, same here. The log file shows the following:


=========================
DARWINIA BLACK BOX REPORT
=========================

VERSION : win32-full-steam-1.5.10
ERROR : 'Error initialising Steam:
Wrapper not implemented
Last error: The system cannot find the path specified.

(3)'

=========================
====== PREFERENCES ======
=========================

ServerAddress = 127.0.0.1
BypassNetwork = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 0
SoundLibrary = dsound
SoundMixFreq = 44100
SoundMasterVolume = 255
SoundChannels = 64
SoundHW3D = 0
SoundSwapStereo = 0
SoundMemoryUsage = 1
SoundBufferSize = 512
SoundDSP = 1
ScreenWindowed = 0
ScreenZDepth = 24
RenderLandscapeDetail = 1
RenderWaterDetail = 1
RenderBuildingDetail = 1
RenderEntityDetail = 1
RenderCloudDetail = 1
RenderPixelShader = 1
ControlMouseButtons = 3
ControlMethod = 1
BootLoader = random
UserProfile = AccessAllAreas
RenderSpecialLighting = 0
Difficulty = 1
LargeMenus = 2
ScreenHeight = 900
CurrentGameMode = 1
AutomaticCamera = 0
ScreenColourDepth = 32
ScreenRefresh = 60
ScreenWidth = 1600
ControlHelpEnabled = 1
ModSystemEnabled = 1

=========================
====== STACKTRACE =======
=========================

retAddress = 0041C40A
[Zeal] KBTKaiser Feb 21 @ 7:34pm 
I'm getting a (2) instead of a (3), but I have the same error as OP
Sergeant Blueforce Feb 22 @ 1:07am 
I know, I have this too, only started to happen a few days ago. Maybe because of a steam update they've changed a few things with the DLL and it causes games that they haven't fixed to crash?
Last edited by Sergeant Blueforce; Feb 22 @ 1:11am
Dax Feb 22 @ 3:23am 
The Darwinia forums appear to be dead. So I've just contacted their support team and provided them a link to the thread explaining the situation, if I hear anything I'll be sure to let you guys know :)
scotty Feb 22 @ 7:08am 
Same here, at first i got the error you get when steam.dll is missing from the folder. I replaced that and now I get the above error. I think its looking in the wrong location for the steam wrapper. I have searched the app manifest in Steam\SteamApps which is 1500 and tried changing the file path in there to Steam\\SteamApps\\common\\Darwinia but this had no effect.
BDRK9 Feb 23 @ 4:24am 
I hope a fix comes along soon. I've never had an error like this before. I feel as though Steam has betrayed me.
ArthurMinute Feb 23 @ 10:24am 
not working for me either. very frustrating
scotty Feb 23 @ 10:59am 
Has anyone contacted steam help about it?
Dax Feb 23 @ 11:07am 
I've contacted Introvision's support because I thought the ball would be in their court. Not got a reply yet and may take up to seven days. If someone wants to get hold of Steam support that'd be good!
scotty Feb 23 @ 12:14pm 
It seems to be a steam error, so would be worth it
SciStarborne Feb 25 @ 6:22pm 
Just had a Steam Update which said it fixed some incidences of broken games.
Darwinia still won't start. Same errors.
The Khemist Feb 26 @ 2:31am 
Still not working here also! =(
Showing 1-15 of 26 comments
< >
Per page: 15 30 50