Prince of Persia: The Sands of Time

Prince of Persia: The Sands of Time

finchch Jun 3, 2014 @ 3:29am
Mouse does not work
Hi any and all-

The game loads and starts with no issues, but when I reach the menu screen, my mouse (Logitech M560 wirless) does not move the cursor. I've never had this problem before and the batteries are fine. Once I CTRL + ALT + TAB out of the game, the mouse works fine again.

Any ideas?
< >
Showing 1-4 of 4 comments
LaserBeamCheck Oct 16, 2014 @ 5:23pm 
I am having the same problem with Sands of Time and Warrior Within, it used to work and now does not. Windows 7, Logitech MUV94 mouse.

Not even my trackpad on my late 2012 Macbook Pro is functioning

Did you find a solution yet to Sands of Time mouse issue?
Last edited by LaserBeamCheck; Oct 16, 2014 @ 5:33pm
finchch Oct 17, 2014 @ 5:33am 
Basically, I uninstalled, reinstalled about three months later, and it worked. Sorry I don't have a more technical fix.
LaserBeamCheck Oct 18, 2014 @ 1:33am 
Seems all I did was restart and it worked, after turning ON triple buffering and vertical syn in "manage 3D setting" for nvidia card, specifically for PoP under program settings. But for anyone else out there just try a restart first. Thanks!
Michelle Dec 13, 2014 @ 7:56am 
Have the same problem and nothing helped me :/ . Not only with this tiitle but with the whole trilogy my mouse will not move. Can´t fix that and was trying also switching the mouses with no success.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50