Far Cry > General Discussions > Topic Details
frostdiamond Mar 2 @ 6:21pm
Weapon model missing?
**I have FCAM mod installed**

All of sudden, after I loaded a game, all my weapons are missing on screen! The reticles are still there, they fire just fine, and I could scroll through them, they even appear on screen when I press RMB to aim.

Any idea why?

First I thought it's a glitch, so I said OK I'll live with this until end of the level. Now I've just reached a new Level (Tree House), and the same problem persists.

Any fixes, folks?
Showing 1-3 of 3 comments
< >
frostdiamond Mar 2 @ 6:22pm 
And if it's of any help, when I load a previous check point where I still had my weaons, all the weapons are back. Just that when I load my CURRENT quick save file, all the weapon models are missing on screen.
frostdiamond Mar 8 @ 4:54pm 
This is happening again. I've just reached the level where Val and I are supposed to "borrow some transportation" in the camp. And the weapon models in my hands have gone missing again!

Not only that, Val's weapon model is missing too - she looks like she's holding an invisible weapon.

I tried re-loading / restarting, neither to no avail. Am I the only one experiencing this issue?
wyomingbillkelso Mar 16 @ 8:07am 
Hi,
It's an FCAM thing. I had that issue as well at the time I played through FCAM. I had some discussion about it with garcy in the comments section of his moddb page. I can't remember if we solved it. Once you get it it will stick with you. I would bypass it by reloading a previous savegame and replaying. But maybe we solved it, honestly can't remember. This was like two years ago or something, can't remember which release of FCAM, so finding the correct comments section might require some sifting through differrent pages.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50