Baby Wolfie Mar 22, 2014 @ 12:01am
Runtime Error! I can't play the game...help?
I have JUST recently purchased and then downloaded this game and I cannot play it. Every time I try, I get the same error. Something about resolution perhaps? It claims that I must delete the "UT2004.ini" file. Problem is that I have already tried doing that, and it never works after I do so. I can sometimes get the game to play if it remains in a tiny window. Below is the actual error message I receive when I try to simply open the game.

------------------------------------------------------------------------------------------------------------------------
UT2004 Build UT2004_Build_[2005-11-23_16.22]

OS: Windows NT 6.2 (Build: 9200)
CPU: GenuineIntel PentiumPro-class processor @ 3503 MHz with 4095MB RAM
Video: NVIDIA GeForce GTX 650 (3182)

Error setting display mode: CreateDevice failed (D3DERR_DRIVERINTERNALERROR). Please delete your UT2004.ini file if this error prevents you from starting the game.
------------------------------------------------------------------------------------------------------------------------

Is there anything I can do to get the game to play? This game is very nostalgic to me, and I looked forward to playing it once again. Please lend me a hand.
Last edited by Baby Wolfie; Mar 22, 2014 @ 12:02am
Showing 1-10 of 10 comments
< >
Z.Ibrahimovic Mar 22, 2014 @ 6:09am 
Re-installing patch 3369 seems to fix loads of issues.
http://www.gamershell.com/download_11747.shtml
ThaineOfIver Mar 22, 2014 @ 8:45am 
Did you purchase through Steam?
And have you been able to run it since you purchased it?
Baby Wolfie Mar 22, 2014 @ 12:37pm 
Yes, I purchased it through Steam. No, I haven't been able to really run the game. It crashes and gives me the error message.
Z.Ibrahimovic Mar 22, 2014 @ 2:17pm 
Did you manually re-install the 3369 patch? Do you still experience this very same issue?
Chris917 Mar 22, 2014 @ 5:26pm 
If win 7, make sure game is running with admin rights. UAC controls and stuff like that. Right click games icon- run as administrator.
Last edited by Chris917; Mar 22, 2014 @ 5:27pm
Baby Wolfie Mar 22, 2014 @ 8:09pm 
I tried installing the 3369 patch and it didn't do anything. Also, I am running Windows 8.1.
Z.Ibrahimovic Mar 23, 2014 @ 3:07am 
Im running Windows 8.1 on my PC and tablet and both run 2k4 without issue directly after downloading.

Can you try the following:
Change this in your ut2004.ini

[Engine.Engine]
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

to this

[Engine.Engine]
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice


An other option is to download my config files and overwrite the ones in the ut2004/system folder: http://redirect.eb-ut2004.com/Desktop.7z


Another option is to install the megapack: http://www.utzone.de/forum/downloads.php?do=file&id=1195_UT2004-MegaPack-+-Windows-Patch-3369
Baby Wolfie Mar 30, 2014 @ 8:08pm 
Originally posted by Z.Ibrahimovic:
Im running Windows 8.1 on my PC and tablet and both run 2k4 without issue directly after downloading.

Can you try the following:
Change this in your ut2004.ini

[Engine.Engine]
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

to this

[Engine.Engine]
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice


An other option is to download my config files and overwrite the ones in the ut2004/system folder: http://redirect.eb-ut2004.com/Desktop.7z


Another option is to install the megapack: http://www.utzone.de/forum/downloads.php?do=file&id=1195_UT2004-MegaPack-+-Windows-Patch-3369

HOLY ♥♥♥♥! Changing the place of the semi-colon from the fourth line down to the first line allowed me to play the game. Thank you! ^_^
Z.Ibrahimovic Mar 31, 2014 @ 3:07am 
Funny enough, you might be able now to go into the games settings and select D3D directx again without it preventing you from booting the game.
H2O May 11, 2014 @ 8:54pm 
Originally posted by Z.Ibrahimovic:
Im running Windows 8.1 on my PC and tablet and both run 2k4 without issue directly after downloading.

Can you try the following:
Change this in your ut2004.ini

[Engine.Engine]
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

to this

[Engine.Engine]
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice


An other option is to download my config files and overwrite the ones in the ut2004/system folder: http://redirect.eb-ut2004.com/Desktop.7z


Another option is to install the megapack: http://www.utzone.de/forum/downloads.php?do=file&id=1195_UT2004-MegaPack-+-Windows-Patch-3369

Thank you so much! I just purchased the game and was having this problem aswell. It was driving me crazy!! Changing the semicolon fixed it!
Last edited by H2O; May 11, 2014 @ 8:54pm
Showing 1-10 of 10 comments
< >
Per page: 15 30 50