yarkamir Sep 12, 2013 @ 7:21am
Unreal 2 will not start direct3D problem
This is what flashes when I try to play Unreal 2 The awakening I have the latest drivers and I have only found one incident of this on-line but there was no resolution found.


_______________________________________________________

Please enable Direct3D acceleration. You can do this by starting dxdiag and enabling Direct3D Acceleration in the Display1/2 tab after installing DirectX 8.1b (or later) and the latest drivers for your graphics card.



Build: Mar 14 2003 13:26:15

_______________________________________________________

here are my system specs

System Manufacturer: ASUSTeK Computer Inc.
System Model: N73SV
Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
BIOS: BIOS Date: 04/14/11 09:31:29 Ver: 04.06.03
Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz (8 CPUs), ~2.0GHz
Memory: 12288MB RAM
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

Card name: Intel(R) HD Graphics 3000
Manufacturer: Intel Corporation
Chip type: Intel(R) HD Graphics Family
DAC type: Internal
Device Key: Enum\PCI\VEN_8086&DEV_0116&SUBSYS_15E21043&REV_09
Display Memory: 1696 MB
Dedicated Memory: 64 MB
Shared Memory: 1632 MB
Current Mode: 1600 x 900 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor

Card type: Geforce GT 540M CUDA 1 GB

I have the latest drivers for everything I even just tried downloading the Directx build that is supposed to make 11 more compatible with everything. Nothing I have tried has worked please if you can help.

Thanks
Showing 1-14 of 14 comments
< >
explosions! Oct 10, 2013 @ 3:26am 
are you sure the game isnt trying to use the intel card and not the geforce 540?
Regent of Skull Mashing Oct 19, 2013 @ 3:36pm 
it still works fine with an intel hd card. I should know, because I have that same graphics card.

In theory, it should work fine with either, but even with reading though your config, it's not entirely clear as to why it's doing this.

Try verifying the cache first, and see if that works. If nothing else, do a reinstall of the game. Have to clear out the obvious first.
yarkamir Oct 31, 2013 @ 8:39pm 
I have been too busy with school and work to worry about this for a while. First off thank you for your replies to my plea sadly I do not know what is causing this I have messed around with my graphics cards configs till I am blue in the face and I have updated directx 11 more times then i would like to count as well. I seem to be the only one with this problem and it is frustrating to say the least. It is probably some obscure driver somewhere messing up the whole thing or some program that is running in the back ground. oddly enough I have three different verisons of this game and have attempted to run all different versions and they all have the same issue. Also Unreal 2004 does the exact same thing.
Thrawn Dec 5, 2013 @ 7:05am 
Hey umm are you trying to run that game from 2003 on direct x 11 only ? LOL, ROFL, LMAO.
No game from former direct x revisions (6,8,9) will use direct x 10 and 11.
No matter what kind of direct x extenders you use, THAT simply won't work.
In best case the unreal engine 2.0 reverts to software mode renderer, using your cpu (not the intel hd, YOUR CPU CORES), in worst case, it won't boot at all or just keep on crashing.
Pls install directx 9c, if you haven't done yet.
(This is needed for all old games before direct x 10)
You will find it here: http://www.microsoft.com/en-us/download/details.aspx?id=35
After that, you will want to look at another thread, because you will run into the next issue :)

If you got it running, but hang on a white screen in the intro, WELCOME TO THE CLUB :)
Here I post you the fix for the next problem, don't add any registry entries, THEY ARE NOT NEEDED FOR WIN7X64.
http://forums.beyondunreal.com/showpost.php?p=2404290&postcount=61
Otherewise you'll have a very sound free, laggy and unstable experience of unreal 2 XD
Last edited by Thrawn; Dec 5, 2013 @ 7:15am
yarkamir Dec 7, 2013 @ 1:34am 
thank you so much the first link you sent did the trick it now works. You would not believe how long I have been trying to fix this and I even pleaded with the company and they didn't have a solution for me so thank you i can now play unreal 2 and unreal tournament 2004 and have been having fun doing so for the past many hours.
Thrawn Dec 7, 2013 @ 5:35am 
Good it worked for you XD
Sry, I just had to be a little sarcastic :) , overall you get your monys worth out of the game.
Well, regarding to contact the company, you know, LEGEND ENTERTAINMENT is no more, they died a long time ago.
I know that, I have both versions, the original CD version and the steam version, the intro is different, in the steam version, the legend entertainment logo is missing .
But something is strange, I could swear you would run into the next issue, do me a favor, start up unreal 2 and let the intro run.
If it gets to the this tunnel of light, it should hang on a white screen infintely while the music still plays. If it does not hang there, then micro$hit has patched it's directx 9 dll's AGAIN *grrr*.

About UT2004, try if you can go and play online, if you can't even after doing the firewall exclusion stuff, contact me again, I know a solution.
Last edited by Thrawn; Dec 7, 2013 @ 5:40am
yarkamir Dec 7, 2013 @ 2:03pm 
ok so first I did as you said in unreal 2 and it did go to a weird white screen with black valley and peaks on the side but I could easily enter and exit it and play the game still. Second I was playing ut2004 online all last night with no problems and I didn't have to do any firewall exclusions. so after the white tunnel of light is your game truly hung or does it just not show the animation any more?
Thrawn Dec 8, 2013 @ 3:37am 
So good ut 2k4 is fine, if it lets you go online, then there is no need to fix anything what is not broken :)

Regarding unreal 2, first here is the full intro, it should look like this and NOT hang on a white screen after some time.
Full intro: http://www.youtube.com/watch?v=4aTVN1SjdFc

So, if yours does not look and run like this, you have a very common problem, all ppl with vista and 7 suffer from this, ultimately you will notice strange audio behavior, crashes, or game breaking bugs where you cannot advance anymore (sevrenaya) not so cool.
The second link i posted, contained the fix you will need, regardless I will post a direct link.
http://www.mediafire.com/download/uzymyuizyym/Win2k3_Diretmusic_Patch.rar
1st: Get that archive.
2nd: extract only the "system32" with those 8 dll's inside, to a place where you can find them and have full read write access (anywhere but not into the windows directory), the registry entries DO NOT extract them, YOU DON'T NEED THEM, THEY WILL DO HARM ON YOUR OS.
3rd: Open another windows explorer and navigate to C:\Windows\SysWOW64
(if you navigate there but don't see any files, you'll want to set your directory view options straight, something like "hide protected system files" and tick that ceck box off)
4th: You should now find in the directory SysWOW64 the same files as in the directory you extracted , exactly 8 files by exactly the same name only the date and file size differs. Yours should be from around 2009 while those in the extracted directory are from 2004.
5th: Now we are on to replace those buggers BUT since they are protected sytems files, you will not be able to RENAME, DELETE or MOVE those. You will need those eight file to be set as YOUR stuff (administrator rights needed), then rename them (DO NOT DELETE THOSE), just change the file extension like dmband.dll becomes dmband.dll.orig.
6th: If you have set the permissions of those eight files, and renamed them, you can now copy those from the extracted system32 to the SysWOW64. There should be NO prompt to overwrite, if there is one, you forgot one or more files to rename, abort copy, rename and retry.
7th: If you replaced those $uckers, start up unreal 2, you should now have a working full intro, without any sound problems, any crashes and without any game breaking bugs.

I hope this makes any sense to you, if you need help with file permission stuff (step 5), post some contact email and I will write a full description with pics on how you do that.
yarkamir Dec 10, 2013 @ 11:06pm 
Thank you so much for you help I just finished playing through the entire game from start to finish it crashed a couple of times but I didn't experiance the issues you talked about. Maybe they did update direct x because I did not try the fix you suggested. The crashes were nothing irregular I experiaced them on my windows xp system stuff like never ending loading screen and crashing to desktop while loading a main level. Like I said this is nothing new for me I remember it doing the same things on my old pc. Any way thanks so much for your help.
Thrawn Dec 14, 2013 @ 4:20am 
No prob :). It's a shame that there is no sequel to this game, I'm hoping for almost a decade that epic will take on the unreal series and bring out an UNREAL III. I want to know what happened to Dalton, why the skaarj were after the artifacts, and what is happening with the KAI.
yarkamir Dec 14, 2013 @ 4:29pm 
a sequel would be very nice like maybe he gets back to civilization to find the KAI running amok having been transformed as well all over the known worlds now that would be kind of fun.
Thrawn Dec 20, 2013 @ 3:00am 
Yep, or maybe in between some skaarj havoc, where his capsule gets picked up by a skaarj mothership and during escape he destroys the whole ship :)
SkaTroM Dec 28, 2013 @ 12:30pm 
& G force gt 220
Thrawn Dec 31, 2013 @ 6:35am 
??? huh?
Originally posted by iSkaTroM Tm:
& G force gt 220
Showing 1-14 of 14 comments
< >
Per page: 15 30 50