Bit Sean Nov 2, 2013 @ 3:35pm
Unreal 2 Fullscreen crash
So, I'm having a problem with Unreal 2 refusing to work unless it's in a window. Attempting to toggle a fullscreen, whether in the options, the Maximize button or Alt+Enter, causes the game to crash, with a slightly different error message depending on the method used but generally similar to this -

Error setting display mode: CreateDevice failed (D3DERR_DRIVERINTERNALERROR). Please delete your Unreal2.ini file if this error prevents you from starting the game.

History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::ToggleFullscreen <- WM_KEYDOWN <- UWindowsViewport::ViewportWndProc <- WWindow::StaticProc <- DispatchMessage <- 0059030A 260 <- MessagePump <- MainLoop

Build: Mar 14 2003 13:26:15

It's set to my native desktop resolution, so I've no idea what's causing the issue. Here are my system specs -


Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x15
CPU Model: 0x2
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 3515 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: AMD Radeon HD 7800 Series

DirectX Driver Name: aticfx32.dll
Driver Version: 12.104.0.0
DirectX Driver Version: 8.17.10.1191
Driver Date: 28 Mar 2013
OpenGL Version: 4.2
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon HD 7800 Series
VendorID: 0x1002
DeviceID: 0x6819
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 26.65" x 15.00" (30.55" diag)
67.7cm x 38.1cm (77.6cm diag)
Primary Bus Type Not Detected
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x

Any ideas?
Showing 1-3 of 3 comments
< >
Melodic Sword Dec 3, 2013 @ 4:08pm 
Open up the Unreal2 config file (Unreal2.ini) and under [WinDrv.WindowsClient] there are values for fullscreenViewportX and FullscreenViewportY. Just change the numbers to your resolution and fullscreen should work, it did for me.
Bit Sean Dec 3, 2013 @ 4:22pm 
Think I tried that? Certainly messed around with the ini file anyway.

Regardless, couldn't fix the problem exactly but ended up just using a Borderless Windowed Gaming program off the net. Thanks for the reply anyway.
Thrawn Dec 7, 2013 @ 6:39am 
Hi there, hmm there is something off in the description, you stated your dx version is "DirectX Driver Version: 8.17.10.1191" while it should be above 9.18.something something...
This is an ati internal driver, so normally I would send you off to amd/ati and tell you getting the newest driver, but your date seems to be well "newer" Driver Date: 28 Mar 2013.
So there are a number of things you could try out even in combination:

1. Turn of antialiasing in the catalyst control panel. (That unreal engine was built for nvidia cards anyway, regardless)
2. Update your direct X version of the direct X 9 runtime, if you haven't done that yet.
You will find it here: http://www.microsoft.com/en-us/download/details.aspx?id=35
3. Update your ati/amd driver package.
4. If none of the above worked, you could still ask help from ati/amd, and tell them they have included an old version of the "DirectX Driver Name: aticfx32.dll".
Showing 1-3 of 3 comments
< >
Per page: 15 30 50