}SoC{Flycrusher1996 Mar 11, 2013 @ 7:24pm
game wont start after I click deploy soldier
I run the americas army 3 application from steam and it pulls up my welcome menu and I click play. A list of servers comes up and when I click deploy soldier, a black box appears for a second and then closes. Whats up? Thanks for your help
Showing 1-11 of 11 comments
< >
USA_Sammy Mar 11, 2013 @ 7:43pm 
do you have a profile yet? If not, see here: http://steamcommunity.com/app/13140/discussions/0/864961722007601107/
}SoC{Flycrusher1996 Mar 11, 2013 @ 7:54pm 
yes, I have a profile, 4 of them to be exact
does any1 have a fix to the problem stated above?
Last edited by }SoC{Flycrusher1996; Mar 11, 2013 @ 8:02pm
silberstein.j Mar 12, 2013 @ 6:32am 
I have the same issue, i cannot get the game to run.
mmchaos Mar 12, 2013 @ 2:53pm 
do you have kerpersky installed?
JUGGERNAUT whiskey tango foxtrot Mar 12, 2013 @ 6:39pm 
i keep getting told there is an issue with punkbuster...
}SoC{Flycrusher1996 Mar 12, 2013 @ 9:06pm 
what is kerpersky? does it come with the original download? where can I get it and how do I install it if I need it for aa3 to work?
WGS_Shaun Mar 13, 2013 @ 2:33pm 
Is it not maybe the games splash ?? i know when i start up i get the AA3 splash displayed for a moment before the game starts... It might just be your pc doesn't load it correctly or something. I say if it doesn't affect your gameplay let it be :D

You can also start AA.exe first from the Steam apps / common / AA3 directory then minimize that and select a server from the play list is steam it should then switch to the already running copy of AA and join the server you just selected.
You should also maybe verify your AA installation might be you have something missing.
Last edited by WGS_Shaun; Mar 13, 2013 @ 2:36pm
}SoC{Flycrusher1996 Mar 13, 2013 @ 8:05pm 
nope, if I run the exe, the splash screen appears for a few seconds, disappears. Then a black box appears for a few seconds and closes. I was able to run this game before it was on steam.
How do i verify my aa installation?
mmchaos Mar 17, 2013 @ 4:31am 
right click the game in steam then properties >local >verify
Pedu Apr 4, 2013 @ 8:21am 
I'm having the same problem. Verifying didn't do anything for me. I click deploy soldier, and it pulls of the splash, but then returns me to the Welcome screen. I tried reinstalling it, but with no success. It's getting really frustrating.
ramiromodica Jul 30, 2013 @ 8:25pm 
same here
Showing 1-11 of 11 comments
< >
Per page: 15 30 50