sirjaime Jan 17, 2013 @ 1:14pm
WTF?!?!?!?
Has any body gottin the servers to load yet in the AA3 game? First Y'all tell me to do this that and the other and that does not work and then some one came on here telling me there is a bug. NOw it's been months since then and ((( I STILL GET NO SERVERS ))), WTF ?!?!?!
Showing 1-15 of 16 comments
< >
Mixu Jan 20, 2013 @ 4:15pm 
NO SERVER LOADING HERE EITHER
sirjaime Jan 20, 2013 @ 9:59pm 
Sorry to hear that, but I am glad to hear I'm not the only 1. Shit and that would be 1 shot 3 kill, we hv 50's now
Last edited by sirjaime; Feb 17, 2013 @ 3:07pm
[AACM]GBGangsta Jan 22, 2013 @ 6:02am 
When you launch AA3 and the loader opens up click the Star icon on the top left and go to options. If you tick the box for "Show server browser after selecting play now" you will get all the servers
[z]et Jan 22, 2013 @ 6:36am 
Yes or the old-school way is: In Steam on the left upper corner is View, click on that then go to servers and change filter to Americas Army 3 u will get all playable servers and maps
Edwin Jan 22, 2013 @ 11:00am 
There is no server browser in game any more. It's in Steam... Was I helpful?
Guttersnype Jan 22, 2013 @ 11:40am 
This is ♥♥♥♥♥♥.T. It's 2013, got a new PC laptop, everything updated, created 2 new accounts, NOTHING. WHY WHY WHY
Last edited by Guttersnype; Jan 22, 2013 @ 11:46am
Guttersnype Jan 22, 2013 @ 11:46am 
Originally posted by R0jkett:
Yes or the old-school way is: In Steam on the left upper corner is View, click on that then go to servers and change filter to Americas Army 3 u will get all playable servers and maps
Not working. Servers come up, clicking server, 'Deploy'-ing a soldier, and I'm back in AA3's Welcome Menu. >_<
Last edited by Guttersnype; Jan 22, 2013 @ 11:46am
mmchaos Jan 26, 2013 @ 7:48pm 
Originally posted by Guttersnype:
Originally posted by R0jkett:
Yes or the old-school way is: In Steam on the left upper corner is View, click on that then go to servers and change filter to Americas Army 3 u will get all playable servers and maps
Not working. Servers come up, clicking server, 'Deploy'-ing a soldier, and I'm back in AA3's Welcome Menu. >_<
are you using kaspersky?
sirjaime Jan 27, 2013 @ 12:36am 
Didn't work
mmchaos Jan 27, 2013 @ 4:02pm 
Originally posted by edwin_83pl:
There is no server browser in game any more. It's in Steam... Was I helpful?
you can also right click your steam icon and click servers then filter by america's army 3
FifthYangPro Jan 30, 2013 @ 7:55pm 
Originally posted by mmchaos:
Originally posted by edwin_83pl:
There is no server browser in game any more. It's in Steam... Was I helpful?
you can also right click your steam icon and click servers then filter by america's army 3
Ive never been able to see servers in the game. I have to leave the game and join from first menu that opens when you click "Play Now" after launching from Steam.
mmchaos Feb 1, 2013 @ 1:00pm 
yep. that's how i do it most times too.
sirjaime Feb 17, 2013 @ 3:05pm 
yeah that's I hv 2 play also
sirjaime Feb 17, 2013 @ 3:08pm 
Originally posted by edwin_83pl:
There is no server browser in game any more. It's in Steam... Was I helpful?
LOL, Well Yeah! slol
Br@!n_Bug Mar 6, 2013 @ 7:02am 
Ingame you can press F1 and then klick on the "AA-Star" and choose Server, that will bring the List but you cant Filter or anything.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50