GRID > General Discussions > Topic Details
EDGE_ELITE Aug 15, 2013 @ 4:02pm
Have I gone deaf? No sound!
For some reason I have no sound at all in this game. The splash screens have audio but as soon as the game hits the main menu, nothing.. Its like someone hits the mute button. Does anyone know of this issue or a way around it? I'm running Windows 7 Ultimate 64-bit, GTX660ti and Realtek Audio drivers. Everything else sound-wise works (no issues with any other games etc)...
Showing 1-7 of 7 comments
< >
Generau Sep 4, 2013 @ 4:36am 
I have same problem :( looking for solution, if i find something i will write it here
EDGE_ELITE Sep 4, 2013 @ 7:16am 
Much appreciated! still found nothing! :|
Bong_Science Sep 8, 2013 @ 5:18am 
This might not be related, but Bioshock did the same thing for me. The fix that worked for me was enabling stereo mix in your sound options.
EDGE_ELITE Sep 8, 2013 @ 3:17pm 
Alright I'll check that out! :) Thanks!
grb2eml May 26 @ 4:57pm 
Just turn on CC.

VAAAROOOOM!
EEEEERT!
SKREEETCH!!!
LOL!
RockBinkie Jun 2 @ 1:00am 
I have found a solution to this problem, well it worked for me on windows 8 64 bit at least.
It was a missing openAL driver so I simply installed this:
http://openal.updatestar.com/licenses
and all is working smoothly again.
EDGE_ELITE Jun 2 @ 6:31am 
Thanks for the feedback :D Tis' a pretty old question now so I appreciate it haha :)
Showing 1-7 of 7 comments
< >
Per page: 15 30 50