GRID > General Discussions > Topic Details
wek31975 Jan 6, 2013 @ 7:22pm
Game does not have support for 1920x1080 Resolution with newer hardware.
Users should try this.

There is a setting to select the screen aspect ratio. The default setting is "Normal", an auto mode that always follows the current resolution's AR.
Selecting a specific ratio will stretch the screen to match the selection. Ratios available: 4:3, 5:4, 16:10, 16:9, 5:3.

An important thing to note is that the game does not support resolutions above 1440x900 and 1280x1024 if a graphic card with less than 512mb is detected. The game might incorrectly detect the amount of vram when using newer graphics cards, which will lock you out of using higher resolutions. Follow these steps to solve this problem:

1) Look for your hardware_settings_restrictions.xml file in your 'system' folder (default for steam version: C:\Steam\steamapps\common\grid\system\), and make a backup.

2) Open the file with Notepad. Scroll down to the bottom, remove the following entry and save the file:

data
res mem="270" maxWidth="1280"
/data

The restriction is now gone and you can play the game at your native resolution.



Be sure to back up the whole game to a external hard drive before doing this. Keep the back up in it's original form. All so, back up the XML. Copy & past it to a New File on your desktop in case you screw it up. It's not that hard. Just be sure to back it up. The XML file that you would be looking for is restrictions.

Put Forum window along side of the note pad window. This will help in referaning the not pad instuction.

This will fix this issue.

Showing 1-15 of 17 comments
< >
GrimWolf Jan 28, 2013 @ 9:42am 
Errm, mine has 1920 with no editing.
Switch0r Feb 1, 2013 @ 9:11am 
Works great for me on 1920x1080 with no editing.
ChimpTits Feb 3, 2013 @ 12:13am 
thanks this worked for me! Just got a new graphics card and the game limited me to 1280 width
PhD in Portal Apr 17, 2013 @ 12:25pm 
Hi, thanks for this. My new build uses a LucidLogix hybrid GPU setting, and even though the monitor is plugged directly into my nVidia card, it detected the memory from the Intel HD4000 onboard graphics instead and locked out the resolutions. Your solution worked a treat!
DriftMachine Oct 18, 2013 @ 6:21pm 
Thanks, fixed my issue. i have the HD7950 Gigabyte AMD Graphics card.
Starider Nov 1, 2013 @ 7:00pm 
Wow dude, thanks so much for helping me get this to run with my new 780 gtx classified!!!
I was at a loss on how to get it to run since swapping out my 580gtx.
Really, thank you!
Rage Nov 4, 2013 @ 7:03am 
Thanks for the info. Worked perfect for my Radeon HD7850's :)
Last edited by Rage; Nov 4, 2013 @ 7:04am
Wolverine 1974 Nov 8, 2013 @ 12:14pm 
Originally posted by GrimWolf:
Errm, mine has 1920 with no editing.

Erm, you and Switch are in the wrong place then.
Wolverine 1974 Nov 8, 2013 @ 12:15pm 
Thanks Wek for taking the time. Worked like a champ.
Lantea Nov 20, 2013 @ 7:21pm 
Considering getting this game, so was trying the Demo and had the resolution limit issue, this worked great to fix the Demo to work at full res, thanks.
Also had to use the i7 cpu edit thats in codemasters FAQ.
I don't know why they don't patch the game so users don't have to do game file editing just to get the game working properly.
sabo_001 Sep 29, 2014 @ 1:30am 
I know this is an old thread but, thanks man! this already helped me twice :D
Maddawg Oct 22, 2014 @ 11:34pm 
Right clicking on System, there is no option to open with notepad?

Opened System anyway and no files: data
res mem="270" maxWidth="1280"
/data
DriftMachine Oct 23, 2014 @ 10:09am 
After making those numbers match your screen size and video ram

try alt + enter if the problem comes back.
[CRG]<<H3L!XX>> Oct 27, 2014 @ 10:23pm 
Thanks!!!!! This mod was necessary on my R9 280X ,I guess because of 3GB DDR5 ram-WORKs PERFECTLY NOW!!!!
Lip_Gloss Nov 10, 2014 @ 2:31am 
Yepp, it works. :)

I ran 1920x1080 on my old gfx. Got a new gfx with 4GB vram and game only let me play at crappy 720-res.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50