GRID > General Discussions > Topic Details
Artorias May 29, 2013 @ 4:30am
Playing Grid with a controller (DS3)
So after setting up my Dualshock 3 (PS3) controller to work with Grid i keep getting a problem where every now and then the camera would just spazz out and spin left and right

any way to fix this? i don't have a 360 controller and i don't really wanna buy one i prefer my PS3 controller

thank you :)
Showing 1-15 of 16 comments
< >
|Ordo| IcemaX May 29, 2013 @ 5:21am 
Try using x360ce.
Artorias May 29, 2013 @ 5:25am 
I forgot to mention I am currently using Better DS3 i will try x360ce
Wilhelm kn8m4r3 [GER] May 29, 2013 @ 8:43am 
Shouldn´t this work without an emulator? I´m using a Hama Blackforce 2 Controller and don´t have any problems, even though it obviously aint a xbox pad oO
Artorias May 29, 2013 @ 10:01am 
See that's what i thought since its still a controller but i don't know its kinda annoying to be fair :( i don't know what to do
The Dude May 29, 2013 @ 2:14pm 
I have been having the same problem with almost every racing game I play Artorias. I still have yet to figure it out. Interestingly, I brought my PC to a friend's house for a LAN party and I used his controller with better DS3 and it worked fine. It didn't spazz out like it does with both of my controllers. Weird thing is that both of my PS3 controllers work fine on the PS3. It drives me crazy. I know several people that use DS3 tool and it works fine for them. I still haven't figured it out. I am about to buy a 360 controller or a game pad.

@Wilhelm kn8m4r3 [GER] - You have a PC game pad. Both PC game pads and 360 controllers are compatible with games without an emulator. PS3 controllers are not formatted for PC use, so you must use an emulator for them.
Artorias May 30, 2013 @ 11:25am 
Ahhh dammit wish the was a solution glad to know i'm not the only one with the problem i can play loads of other games on Steam with a PS3 and not have the problem! Far Cry 3, Skyrim etc it only seems to effect Racing games, Grid and Dirt 3 both have this problem

thanks for replying The Dude :)
carma143 May 31, 2013 @ 5:50pm 
I have the same issue to. It's a great game and all but the spaz thing is a letdown. I'm trying to set the deadspace for the right analog stick and it seems to be working a bit. Might set deadspace to 200 for both the x and y axis in Options of the DS3 controller
carma143 May 31, 2013 @ 6:00pm 
I was able to eliminate the stuttering by disabling the right stick in DS3
aker May 31, 2013 @ 10:31pm 
For PS3 controllers an excellent alternative is MotionInJoy.
Also, you could Try xpadder. Solved all my problems with Grid and my controller (PS)
Artorias Jun 1, 2013 @ 10:54am 
Ak3r noooo way dude MotionInJoy gives you tons of spyware and other junk!

Carma143 have you fixed the problem totally? i just have to disable the right stick? if so you are a life saver!
carma143 Jun 1, 2013 @ 10:57am 
ya. It completely fixes the stuttering. But still every once in a while the same happens to the left stick so you move slightly to the left or right, but that really isn't a big deal because that can only happen when your not already using the analog stick (the stuttering only happens when the analog stick is in the center.. If you can't figure out how to disable it on DS3, I'll help you.
pseudex Jun 3, 2013 @ 1:04pm 
you also can use motioninjoy. with this you can easily emulate your ps3 controller as xbox controller.
carma143 Jun 3, 2013 @ 4:14pm 
From what I understand DS3 is from Motionjoy. I went to the Motionjoy website and that is where I downloaded the DS3 Tool.
FrancisUK1989 Jun 4, 2013 @ 7:02pm 
I had so many issues with the PS3 controller but did end up buying a Xbox 360 wired pad for £9.00 pounds on ebay but the only trouble is, Its heavy but is getting used too. http://www.microsoft.com/hardware/en-us/d/xbox-360-controller-for-windows
Stery Aug 21, 2013 @ 10:32am 
Hey, sorry for revining this old discussion, but I also have this problem. But I've encountered it only when the controller is connected via cable to PC(for charging), no problems while connected via bluetooth so far. I also have this problem in Test Drive Unlimited 2(I can't remember if i had it only when the controller was connected via cable). Have you managed to fix it? Tell me what you did please :)
Showing 1-15 of 16 comments
< >
Per page: 15 30 50