Chief Popasquat Jul 23, 2013 @ 8:10pm
Fix your damn game
I was a huge fan of this game when it came out and have over 800 hours logged but i havnt been able to play it properly in months. I have a decent computer that should be able to run KF easily but ever since the first weapon update the game plays like ♥♥♥♥. Zeds jump around everywhere, it takes a full 3 seconds or more for enemys to take damage/react to a hit, and movement is chopy as all hell. Zeds will sometimes ignore my presence completely and jump around in nonsense directions rather than moving smoothly as they used to. My settings and ping are both low but the problems persist the game is virtually unplayable as it is. Tripwire needs to stop trying to milk money with more gun/skin packs and fix the basic mechanics of their game. Has anyone else noticed the decline in gameplay quality/smoothness or is it just me?
Showing 1-15 of 20 comments
< >
Alph Jul 23, 2013 @ 9:11pm 
Idk but my ping is now like 66 one second and 999 the next. Doesn't matter the server or anything I do on my end to fix it.

QueenVaginosaur Jul 23, 2013 @ 9:12pm 
Game's fine to me
Speke Jul 23, 2013 @ 9:27pm 
Game is fine for me...
WeeWee Jul 23, 2013 @ 10:34pm 
Im pretty sure that something is wrong your game and/or connection
Royロイ Jul 23, 2013 @ 11:05pm 
esyethe
Capt.Overkill Jul 23, 2013 @ 11:16pm 
Lol, the problem is on your end mate. Did you try to fix any of the issues you were suffering from? Did you check Biggins guide? You can't just blame TWI for something that is an issue with your computer/how the game works with your computer. Do you have a custom rig?
THEPYROMAN Jul 24, 2013 @ 12:07am 
im having a problem to every time i get to a level 3 sharpshooter(thats my goal to get to three) i finish the all the waves and brings me to the next map(i play solo) when i press disconect and i am a the main menue i check mt profie and whaaa im a leve two sharpshooter HELP(oh the map i plar is snipers yard)
Forever Squishy Jul 24, 2013 @ 1:58am 
Originally posted by RMTRMT:
im having a problem to every time i get to a level 3 sharpshooter(thats my goal to get to three) i finish the all the waves and brings me to the next map(i play solo) when i press disconect and i am a the main menue i check mt profie and whaaa im a leve two sharpshooter HELP(oh the map i plar is snipers yard)

1) wrong thread, there are others out there for this
2) probably a non-whitelisted map
WeeWee Jul 24, 2013 @ 1:59am 
Whitelisting is removed
Capt.Overkill Jul 24, 2013 @ 6:48pm 
You have to die, then you hit forfeit. That should save your data.
Chief Popasquat Jul 25, 2013 @ 11:49pm 
Thank you, its comforting to know that the problem isn't universal. I wasn't sure and thats why i made this thread. I just find it odd that the game has these issues since yes i have tried fixing the issues on my own and until the first set of weapon add-ons the game ran fine on my computer.
Bigguns 93 Jul 26, 2013 @ 2:00pm 
make sure your version of KF is up to date. Sometimes it gets out of synch. Delete your killing floor system folder then verify your game cache, that will force the lastest version onto your pc.

The Summer event caused some of the issues, are they gone now?

Guide below has some fixes
http://steamcommunity.com/sharedfiles/filedetails/?id=125107851
Big Chimpin Jul 26, 2013 @ 2:12pm 
Yeah I'm not having any problems on my end. I'm going to assume you've already tried sorting the server list by ping?
-=HOL=- Ravenfrost Jul 26, 2013 @ 2:40pm 
Idk what happened with my kf, but i was trying to get some lvl's with my comand when i noticed that every game the number of stalkers killed by me are the same 1823, this number never change.
Chief Popasquat Jul 29, 2013 @ 12:22am 
The game seems to be working fine now. I think the glitches did have something to do with the summer event because problems stopped when it ended.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Jul 23, 2013 @ 8:10pm
Posts: 20