Killing Floor

Killing Floor

View Stats:
.
.
Last edited by ❄Evelyn Under The Mistletoe❄; Jul 11, 2015 @ 10:50pm
< >
Showing 1-12 of 12 comments
TinehPhoenix Feb 27, 2013 @ 1:05pm 
Dedicated server?
TinehPhoenix Feb 27, 2013 @ 10:02pm 
Listen servers are easy, just start the game, click "Host Game" in the main menu, and the choose what mutators, map, difficulty and that stuff you want and then just click on "Listen" at the bottom right corner. And this is for hosting a dedicated server http://wiki.tripwireinteractive.com/index.php/Dedicated_Server_%28KillingFloor%29
MRU♠ Feb 28, 2013 @ 1:00am 
I can only answer for listen servers and it sounds like the problem is that you have to open some ports in your firewall. When you click on host game you see the ports I'm talking about. People cant join if they are not open.
TinehPhoenix Feb 28, 2013 @ 3:31am 
Try and see if your friend can join if he right clicks in the favorite or internet games tab and click on "Open IP" and then manually writes in your server IP, if that doesn't work I guess it's firewall problem or router like MRU said.
Last edited by TinehPhoenix; Feb 28, 2013 @ 3:36am
Drain Feb 28, 2013 @ 11:39pm 
If you're using a Router, you can't host on a video game without forwarding the dedicated ports on it in its configurations. This is because they will, by default, block foreign connections trying to come through it. This results in people not being able to "see" your game. Games will produce error messages saying "not found" or "not responding". You need to Port Forward ON the Router, using any and all ports used by the game, to fix the issue. You could also drop the Router and plug straight into the modem, bypassing the entire issue. But then you'd only have 1 PC plugged to the internet. By having a Router, I assume you want >1 PC with internet connectivity. How to Port Forward varies on every Router, but it is very easy to do on Linksys and Belkins, which are most common.

Firewalls also block the connections, again requiring you to safe list the game, the ports, or to simply turn it off, in order to get the connections through to you.
Buck213 Mar 1, 2013 @ 2:38am 
Here[portforward.com] you can find guides to forwarding ports on many different routers for many programs/games.
Buck213 Mar 1, 2013 @ 3:31pm 
The portforward guides didn't help you figure it out?
Krahazik Jul 3, 2013 @ 6:31pm 
doesn't tell me which ports for Killing Floor need to be forwarded. Just how to do it.
lolwut, I portforwarded my router when I was like, 12...

Anyway, I'm also having this same problem. I already configured my router AND opened the ports in the firewall and my friends STILL can't join me!
ComplaintBox Oct 19, 2014 @ 10:03am 
I tried to but it keeps on giving me errors
Tenshinen Mar 30, 2015 @ 11:45am 
My router doesn't even HAVE port forwarding options.
Last edited by Tenshinen; Mar 30, 2015 @ 11:45am
Fallen Angel Yohane Mar 30, 2015 @ 12:22pm 
Originally posted by Tenshinen:
My router doesn't even HAVE port forwarding options.

And you had to reply to a 6 months old thread to say it? Look harder though, it must be there.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Feb 26, 2013 @ 9:33pm
Posts: 12