Darrell Jan 26, 2013 @ 8:14am
The Game Simply won't launch
No matter how many times I change the configuration settings, and change the compatibility mode, the game still won't launch, and I feel ripped off. Some people have suggested rolling back my drivers, the answer is NO. I just want to play this game, afterall it is one of my favourite games, and none of the other discussions have helped me. Any suggestions?
Showing 1-15 of 17 comments
< >
2MuchCoffeeMan Feb 10, 2013 @ 12:31pm 
the thing that worked for me, and im running win7 64bit, open the directory where your steam games are located, for me that was : C:\Program Files (x86)\Steam\steamapps\common\Port Royale 2..... open it........

try to find a file called pr2.exe, right click on that file, go to the tab "compatibility" or something called like that, and check the top most option in that tab, select run it as win98/ME.
that made the game work for me in fullscreen mode, even if i uncheck the run in fullscreen option in the config tool..

i hope this will help....
Darrell Feb 10, 2013 @ 12:53pm 
I stated i changed the compatibility mode many times, just wouldnt work. I have left it unplayed since I bought it, shame, tis a good game
2MuchCoffeeMan Feb 11, 2013 @ 12:50am 
oh lol sry, welll that was the only thing that worked for me, i even installed it again to try, and with compat. off, it does the same, compat. on, it works......

try fiddeling with the config tool, in combination with the compatibility on win98/ME

you sure youre putting the pr2.exe file on compat. and not other file ??? is it perhaps possible you changing the wrong file ???

may i perhaps know, what vidcard youre running, and wich operating system ? like 9/10 guys the compatibility works, on win7 64bit, that is ....

Darrell Feb 11, 2013 @ 8:48am 
I have Windows 8 64bit (which might be the problem), and I will just give you my specs:
8GB RAM
4x Intel i5 3330 3.0GHz processors
AMD HD6670 2GB GDDR3 Graphics card
2TB Hard drive.
I generally think my computer is just too far ahead of the hardware required to make games such as Port Royale 2 compatible.
2MuchCoffeeMan Feb 11, 2013 @ 2:09pm 
ye well, alot of guys can make it work with win 7, but win 8, thats a whole different story to be honest, not alot of people are running on win 8 yet....

perhaps try port royale 3 or a patrician game, thats the same, but then in europe and GB, i think ...
Darrell Feb 11, 2013 @ 2:11pm 
Tried port royale 3, it didn't fulfill my expectations. I spent around 500 hours on the original port royale, and i might give aptrician a shot some day, got a few other games I would like to try out first. But thanks for your avice.
2MuchCoffeeMan Feb 11, 2013 @ 2:12pm 
toobad there wasnt any result though :D gl
Achasson Mar 23, 2013 @ 3:32pm 
You might want to try installing older ATI drivers. I remember changing my drivers back to version 12.3 and then the game launched.
bizarf Mar 24, 2013 @ 6:53pm 
Originally posted by Ebannaw:
You might want to try installing older ATI drivers. I remember changing my drivers back to version 12.3 and then the game launched.

Yeah I'm guessing the AMD drivers messed up something too as I could play this game before just fine.
NoHappyEnd Mar 26, 2013 @ 12:44am 
Yeah guys I got the same ♥♥♥♥ as this guy ... it won't launch no matter what I do, like srsly, I actually didnt even want to buy the 2nd game but the first one, sincei couldn't find it anywhere anymore i decided to get this one, I guess it was a huge mistake doing this ... @ToomuchCoffeeman I did everything you said, won't work, + checked if my drivers need an update ... Won't run.
NoHappyEnd Mar 26, 2013 @ 12:51am 
And who the f would actually change drivers back just to play a game this is ridicolous ...
2MuchCoffeeMan Mar 26, 2013 @ 2:13am 
uhm, thats PC gaming, i bet youve never played games on the pc in the 90s.......

dont buy old games then..... dont expect to run a streetfighter 1 SNES game on your xbox, it wont run either ......

>.>
Darrell Mar 26, 2013 @ 8:49am 
I'm not rolling back my drivers -_-. Dang it I hate W8
Cardinal_UK Apr 9, 2013 @ 8:37pm 
Originally posted by ToomuchCoffeeman:
the thing that worked for me, and im running win7 64bit, open the directory where your steam games are located, for me that was : C:\Program Files (x86)\Steam\steamapps\common\Port Royale 2..... open it........

try to find a file called pr2.exe, right click on that file, go to the tab "compatibility" or something called like that, and check the top most option in that tab, select run it as win98/ME.
that made the game work for me in fullscreen mode, even if i uncheck the run in fullscreen option in the config tool..

i hope this will help....

Worked perfectly, thanks very much.
Sebb7y Aug 19, 2013 @ 1:16am 
Originally posted by Darrell:
I'm not rolling back my drivers -_-. Dang it I hate W8
Yep,I I got the game with GOG and instead of not launching, the water bugs out completely.
Btw my specs:
Windows 8 (64-bit)
8GB RAM
Intel i7 processors (not bothered to list the whole thing out) 2.4ghz
Showing 1-15 of 17 comments
< >
Per page: 15 30 50