Port Royale 2

Port Royale 2

chrisg Jan 24, 2013 @ 8:49am
How to get game to launch in Win7 64bit
In steam, right-click Port Royale 2 in your Library.
Go to Properties, then click the "Local Files" tab. Then click the button "Browse Local Files."
When Windows Explorer comes up, scroll down until you see PR2.exe.
Right-click and go to properties. Then click the "Compatibility" tab.
Select the checkbox "Run this program in compatibility mode for.." and then select "Windows 98/Me" from the dropdown.
Hit the Apply button.
Restart Steam.
You should now be able to launch the game.

Edit: You may have to also do this for the other two executables in your install directory (except the Uninstall exe).
Last edited by chrisg; Jan 20, 2014 @ 8:38am
< >
Showing 1-15 of 16 comments
Nope. Definitely doesn't work. ATI Graphics drivers are what effects this. Anything above 12.8 seems to crash it.
[hswak] Sebb7y Aug 19, 2013 @ 1:19am 
Originally posted by SIR CHUMPDICKS OF GAGALHARDLAND:
Nope. Definitely doesn't work. ATI Graphics drivers are what effects this. Anything above 12.8 seems to crash it.
Whattabout the graphical problem 4 water
cat say µ Dec 3, 2013 @ 12:03am 
Didn't work for me - running a gtx 560 ti, win7 home premium 64 bit. Haven't bothered attempting a driver rollback and not going to.
johnrob Dec 16, 2013 @ 1:49am 
It worked for me, AMD user running catalyst 13.9 drivers win7 64bit pro
Lord_Kalvan Jan 10, 2014 @ 6:48am 
I had to enable compatibility mode for all 3 executables in the game directory (except the uninstall executable) but then it worked for me.
But I am not sure why it is necessary in the first place to use compatibility mode with the steam version since there was a (german only?) version published a few years ago which worked without having to enable compatibility mode on vista/win7.
Ursurper Jun 4, 2014 @ 6:21am 
Doesn't work for me 2.
Fun thing is that after try to start it,you have to close the Pr2.exe in the Task Manager on Process tab.
But for fact,no matter which Game,Compatibily Mode never helped me on older Games.
Always some Mods or other workarounds.
Numaest Jun 27, 2014 @ 5:30pm 
I've got 14.4 and it eventually ran under win98/me compatibility.
turribel Jul 26, 2014 @ 7:43pm 
If you are not able to run it under compatibility, disable the DEP for PR2
Castor Troy May 6, 2015 @ 10:02am 
Run it with intergrated graphics using Nvidia Control Panel, worked for me without using compatibility mode
MOOSE! Rorius May 17, 2015 @ 5:13am 
Originally posted by Lord_Kalvan:
I had to enable compatibility mode for all 3 executables in the game directory (except the uninstall executable) but then it worked for me.
But I am not sure why it is necessary in the first place to use compatibility mode with the steam version since there was a (german only?) version published a few years ago which worked without having to enable compatibility mode on vista/win7.

This worked for me in windows 8.1 64bit, I also used another posting found here http://steamcommunity.com/app/12470/discussions/0/627456486665779788/ and it seemed to get the game to work, no graphics driver changes. I don't know if both are required, but that seemed to get it working.

Wobba [N7] May 19, 2015 @ 11:45am 
It worked for me thx :D great memories on my childhood
Crazed Possum Oct 21, 2015 @ 3:01pm 
If anyone else has problems starting this game in Windows 7 64 bit this is what i had to do:

Add the game's executable to the DEP list. If you don't know what DEP is then just Google it. It's under Control Panel-System-Advanced system settings-(advanced TAB)\ performance-click button that says: Settings......when the list comes up click the tab at the top : Data Execution Prevention. Select : Turn on dep for all execept for what i select and you'll have to navigate to the game's executable and add it to the list. I had no problems after that. Hope this helps you all out.

Possum
netnerd85 Nov 30, 2015 @ 10:32am 
Anyone having issues with the mouse/scroll speed being really fast? (Win7 64 bit)
Camel Feb 23 @ 11:59am 
Go to instalation directory and rename Videos to Videos1. Work for me. Windows 7 64bit Ultumate.
Pherim May 12 @ 11:34am 
Originally posted by Castor Troy:
Run it with intergrated graphics using Nvidia Control Panel, worked for me without using compatibility mode
I can confirm that with integrated Graphics (Intel HD on my Laptop) it appears to be working flawlessly without compatibility mode (Windows 10 Pro 64bit). Don't know about people with only AMD hardware, and I haven't checked on my desktop PC.
Last edited by Pherim; May 12 @ 11:35am
< >
Showing 1-15 of 16 comments
Per page: 15 30 50