Sacred Gold

Sacred Gold

Sacred Gold > Dyskusje ogólne > Szczegóły tematu
Sacred Gold Low FPS and Sound Problems FIXED!
I found solution to low fps and sound problems in game. All you have to do is to set your Desktop resolution to 1024x768 and uncheck Fullscreen mode in Config.exe in game folder.
< >
Wyświetlanie 1-13 z 13 komentarzy
Nuku 22 Sie, 2013 - 18:04 
I noticed with the non-steam version that it became really slow on newer PC's, i read somewhere that you can turn off vsync in some config file, but didn't even think of this solution (which is way better), thanks!
Ostatnio edytowany przez: Nuku; 22 Sie, 2013 - 18:04
Nuku 22 Sie, 2013 - 18:09 
What i noticed with alot of old games that support windowed mode but don't support high resolutions: somehow the windows startbutton is taking up loads of resources when it's even with 1 pixel on screen, covering the whole start button solves this issue...
This is why changing your desktop to the game's resolution fixes this problem.
brshers 18 Wrz, 2013 - 6:41 
What i noticed with alot of old games that support windowed mode but don't support high resolutions: somehow the windows startbutton is taking up loads of resources when it's even with 1 pixel on screen, covering the whole start button solves this issue...
This is why changing your desktop to the game's resolution fixes this problem.
hi, how did you find that?
Aeon2927 30 Wrz, 2013 - 8:54 
Settings.cfg
GFX_LIMIT128 : 1
GFX32 : 0
FULLSCREEN : 0
FSAA_FILTER : 0
done
Gizmo 2 Gru, 2013 - 2:13 
I'm thinking og buying this. I actually own the original but it never worked as i had those sound problems and FPS slowdown as many people experienced on their new computers.
Are people still having this problem?
Is the only fix really to reduce desktop rez and full screen as outlined here?
OR has it been fixed properly whereby you can leave your desktop alone.
Nuku 14 Gru, 2013 - 11:47 
What i noticed with alot of old games that support windowed mode but don't support high resolutions: somehow the windows startbutton is taking up loads of resources when it's even with 1 pixel on screen, covering the whole start button solves this issue...
This is why changing your desktop to the game's resolution fixes this problem.
hi, how did you find that?
I had low framerate/stuttering problems with other older games running in windowed mode, but fullscreen or windowed fullscreen didn't have this problem, so i just tried moving the window to various places on screen and found out it was the startbutton that was causing all the trouble (this was in Win7 64bit)

Ofcourse this won't work for everything, but it's worth a try
Ostatnio edytowany przez: Nuku; 14 Gru, 2013 - 11:48
GnarfDude95 30 Lip, 2014 - 23:24 
Hi. i found a much better soulution for win.Vista to solve this problem:just right click on Sacred.exe
then click on properties.then compatibility ..then select the compatibility mode Windows xp(service pack 2) ((or whatever)) if this wont work for you then try comp.mode win95/98....
thanks for reading and much fun in sacred!!!
Skrei 19 Sie, 2014 - 4:40 
mswsquad:
I found solution to low fps and sound problems in game. All you have to do is to set your Desktop resolution to 1024x768 and uncheck Fullscreen mode in Config.exe in game folder.
Many thanks. It works like a charm.
icotech852 12 Paź, 2014 - 12:45 
right click on Sacred.exe - properties - and set run like in Windows 98 and ME
right click on Sacred.exe - properties - and set run like in Windows 98 and ME

This worked for my GOG install. Easiest fix available it seems.
Just installed Sacred gold from the disc with portal 2 included....but the fps is just bad,when i play i only get a max of 20 fps but if i go in the options while games is paused it shows the 60 fps mark.Can someone help?

Specs:(not very impresive i know)
Intel Celeron N2480 2.16 GHZ
Intel HD graphics i think it was Valley view
4GB RAM Single slot DDR3
All drivers up to date
Windows 10
Ps:Sorry for my english,Im from Romania :)
I'm using the GOG Version, so I can't guarantee that this stuff works the same for other versions of the Game, since many Versions on GOG are a bit updated, so they work better or at all on newer systems.

Info about the Problem:
The Problem seems to be the resolution, however they did it, the rendering on higher resolutions is crap. I think they also don't separate the visible Field from the Resolution(was quite obvious with earlier versions, where you could see way more if you've overwritten the resolution to FullHD for example, also the resolution may jump up if you zoom in, independent from the objects on the screen).

Solution:
1.Running the game in a lower resolution(which is already suggested in this thread), but you don't need to change your Desktop resolution for that.
If you have a Desktop-shortcut:
rightclick it and select properties an select the Field "Target:" an go to the end of that field, there you enter the following;
-width XXXX -height YYYY
where XXXX and YYYY must be replaced with the values for the resolution you want to run it, for example:
-width 1280 -height 720
it doesn't need to be a 4:3 resolution, but depending on your version it may look better, also of course don't set it to high or you'll gain nothing, just try out what works for you.

If you don't have a Desktop-shortcut, just create one, alternatively i think you can add those flags in steam when you rightclick and select properties on the game, you can select "Set launch options" which opens a field where you can put these flags, however I'm not sure about if it's really the same thing or something specific for steam flags.

2. Running the game in compability mode for Windows XP or Windows 98/ME may help, especially 98/ME removed in my case flickering during loading screens(otherwise nothing useful i think)
< >
Wyświetlanie 1-13 z 13 komentarzy
Na stronę: 15 30 50

Sacred Gold > Dyskusje ogólne > Szczegóły tematu