Sacred Gold > General Discussions > Topic Details
srozear Mar 30 @ 5:08pm
Graphics glitches
I've been having these glitches with weird artifacts and jagged shapes randomly popping into place. I'm putting in a few screenshots below. I have Windows 8.1, laptop with intel/amd switchable graphics. This problem happens no matter which graphics card I use. I've tried running it in all different compatibility modes, fullscreen or windowed, 32-bit or not. Any advice?

[IMG]http://i.imgur.com/CNyjNI5.png[/img]
[IMG]http://i.imgur.com/zr1Reqs.png[/img]
[IMG]http://i.imgur.com/TZrVtjc.png[/img]
Last edited by srozear; Mar 30 @ 5:09pm
Showing 1-12 of 12 comments
< >
K.Porkchop Sandwiches Apr 1 @ 8:20pm 
I get the same thing and have Intel 4000. After doing some research, the game isn't compatible with Intel graphics, and there doesn't appear to be any way to change that.
srozear Apr 1 @ 9:54pm 
That seems strange because I've tried forcing it to use the AMD card as well. I guess there's something linking the two that I don't know about. It's a shame, though. Thanks for the reply!
Grey Aside Apr 2 @ 6:05pm 
The game is compatible with DX7 and DX8 - many recent graphics drivers gain speed by losing compatibility with these old games.

Search for fixes to more popular games that use DX7 or DX8

I've found myself that nVidia cards after the 8800 can't do older games at all. ATI/AMD cards seems to be fine.

Looking at your screenshots I wonder if there is an option for anti-aliasing or such that you have enabled that is ruining things..?

The corruption seen is usually the type when memory is overclocked or failing.

My only other suggestion is to install the latest DirectX Redistributable.

Sacred can be a temperamental beast.



srozear Apr 3 @ 11:37am 
Thanks! I've looked into that stuff a bit but I can't really find anything helpful. I'm not overclocked and I've tried all options related to anti-aliasing, etc. in both the game config file AND the ATI/AMD control panel.
Danjho12 Apr 4 @ 9:43am 
Ok I had the same glitches and my graphic card is nvidia geforce gt 720m. I have spent about 3 or more hours trying to fix this thing, and finally fixed it. I just played 3 hours of this game and there was no problem. I know you don't use nvidia, but if amd work similar to it then maybe you can fix it too.

This is what I did.

Control panel - Hardware and sound - Nvidia control panel - 3D setting

And you will see that there are number 1.,2., and 3.
For 1. I clicked add and added Sacred
For 2. I chose High performance Nvidia processor

Then the game had no glitches!!!

I don't own any computer that uses intel or amd. So I wouldn't know, but if you have control panel for intel/amd like I did for nvidia, maybe it can be fixed.
I hope this helps :(
srozear Apr 9 @ 10:18am 
Thanks, everybody. I got word from the game's tech support people that the Intel 4000 integrated card isn't supported. I tried to force the game to use the AMD/ATI card in the Catalyst Control Center, but when I load the game and use the switchable graphics monitor, it appears that Sacred.exe is still running the power saving or Intel card. I guess until I figure out a way to truly force the game to use the AMD card, I'll be out of luck.
Danjho12 Apr 14 @ 7:36am 
That's too bad D:
nordtroll Jun 2 @ 7:33am 
Originally posted by Danjho12:
Control panel - Hardware and sound - Nvidia control panel - 3D setting

And you will see that there are number 1.,2., and 3.
For 1. I clicked add and added Sacred
For 2. I chose High performance Nvidia processor

Then the game had no glitches!!!

That worked for me and my Nvidia, thanks!
Solun Jun 8 @ 6:15pm 
Same problem here. I´m having the issue as soon as I start a new game on both of my laptops - one with Intel HD 4400 and one with GeForce 750M.
Solun Jun 8 @ 6:27pm 
I´ve tried the solution posted by Danjho12 but it didn´t work. The game didn´t even launch (I could hear the sound at first but then it stopped working and I had to force close it) :/
UABBlazers Jun 17 @ 3:05am 
Originally posted by Danjho12:
Ok I had the same glitches and my graphic card is nvidia geforce gt 720m. I have spent about 3 or more hours trying to fix this thing, and finally fixed it. I just played 3 hours of this game and there was no problem. I know you don't use nvidia, but if amd work similar to it then maybe you can fix it too.

This is what I did.

Control panel - Hardware and sound - Nvidia control panel - 3D setting

And you will see that there are number 1.,2., and 3.
For 1. I clicked add and added Sacred
For 2. I chose High performance Nvidia processor

Then the game had no glitches!!!

I don't own any computer that uses intel or amd. So I wouldn't know, but if you have control panel for intel/amd like I did for nvidia, maybe it can be fixed.
I hope this helps :(

This also worked for me. I had been having lots of issues with the game on Steam (to the point of crashing my laptop entirely) and recently got the game cheap on GOG hoping to bypass the issues. The crashing was solved using the GOG version but the graphics issue happened. This makes it run very smoothly though. Thanks.
Solun Jun 17 @ 9:06am 
It works for me now - tried both GOG and Steam version and they both work now. Not sure what exactly was I doing before (or what was the game doing) but now the same procedure helped solve the issue.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50