7th-Cylon Nov 9, 2012 @ 9:47pm
seculauncher failed to start application 2000 (windows 8)
I can't open the game, this error always comes up, I tried installing it uninstall vcredist_x86 but the error continues. Anyone know fix it?
Showing 1-15 of 42 comments
< >
Jez Jan 3, 2013 @ 12:38pm 
Same problem with me, I hate this.
pizzz91 Jan 3, 2013 @ 2:34pm 
yeaah...same problem for me too... can anyone help us to solve this.. I also using win 8
Seijinho Jan 4, 2013 @ 6:03am 
Same problem with EFLC. The game successfully launched the first time, I picked Tony's story, could see the initial dialog and stuff, pressed START to skip and the game crashed. Now I can't launch the game at all, always get this SecuLauncher 2000 error.

Checked the game cache, Steam says it is fine.

Had 2 Visual C++ 2005 installed, uninstalled both, restarted, installed Visual C++ 2005 x86 as suggested at some websites, restarted, but the problem persists.

Tried the "Play offline" option, tried to login with my Rockstar account, no luck.

Running Windows 8 Pro x64, Radeon HD 7970 with 12.11 Beta 11 drivers, Windows Update says I have no updates to install.
pizzz91 Jan 5, 2013 @ 3:34am 
so.is there any ways that can enable user especially who r using windows 8... really need help... and I also still confused.. how can I know I have the EFLC..coz at my account detail just state gta iv comple edition or something like that...
ResidentEvilOutbreak Jan 5, 2013 @ 5:08am 
it will NOT work on 8. No matter what you do. Its because Securoms version IV uses is not compatible with 8. this is a known 8 issue. So many games using the same securom version are rendered unplayable. Sorry.
Seijinho Jan 5, 2013 @ 7:13am 
Originally posted by rogerscameron:
it will NOT work on 8. No matter what you do. Its because Securoms version IV uses is not compatible with 8. this is a known 8 issue. So many games using the same securom version are rendered unplayable. Sorry.

Awww D:
Sent an e-mail to SecuROM with a log file attached, hope they can fix it somehow.
Krebs Jan 6, 2013 @ 10:52am 
Unfortunately, I am also having this problem. GTA IV worked fine on Windows 8 until about a week ago, when I tried to play it, and I got the error. I attempted to play it by running the "LaunchGTAIV.exe" file(as Administrator), and it worked for about a day. Then, I got to the loading screens, and I started getting the error again.

Since then, it has not worked, and I am very disappointed, because GTA IV is my favorite game. My computer is brand new: only about 3 weeks old, and everything else works fine(for Windows 8). Because I was having this problem, I have attempted to install Windows 7, in hopes of fixing this problem. However, I had no success, because the Windows 7 install wouldn't let me install the OS on my primary drive, my partitioned drive(both have about 500gb, so size isn't a problem), or ANY of the others! And yes, I did all the necessary things to boot from disk, etc.

I have:

8gb of RAM
1TB Hard Drive
Intel Core i7-3630QM CPU @ 2.40 GHz
Intel HD Graphics 4000
Windows 8(obviously, or else I wouldn't be having this problem)

Thank you in advance for your help
Seijinho Jan 7, 2013 @ 1:47pm 
I've been talking with SecuROM's tech support, they sent me an updated LaunchEFLC.exe file (version 0.1.0.9), but that didn't helped too.

So, I decided to try a few more things, and I think I got the answer lol
If you launch the game using Steam, you get the SecuROM 2000 error. But if you go to the game's folder, right click the file and "Run as administrator", the game will run. If that solves the problem for you, let us know.

I'm not running the game from "Program Files" folder, could that be the cause? All my games are in another HDD because my main is a SSD. The path: D:\Games\PC\Steam\steamapps\common\Grand Theft Auto IV Episodes from Liberty City\EFLC

BTW, can't get GFWL to run, so I still can't play the game LOL
Krebs Jan 7, 2013 @ 2:12pm 
I also tried to run the LaunchGTAIV.exe file as administrator, but to no avail.

By the way, you do not need GFWL to play. All that has to be done is to download "xlive.dll"(Google "♥♥♥♥♥♥♥♥♥") and put the file into your game folder.

Hope I helped!
Old Niko Jan 7, 2013 @ 5:25pm 
Set gfwl to run as administrator.
Seijinho Jan 11, 2013 @ 10:49am 
Originally posted by Krebs:
I also tried to run the LaunchGTAIV.exe file as administrator, but to no avail.

By the way, you do not need GFWL to play. All that has to be done is to download "xlive.dll"(Google "♥♥♥♥♥♥♥♥♥") and put the file into your game folder.

Hope I helped!

Sorry for the late reply. Thanks for the tip, EFLC is working fine now!

- Downloaded ♥♥♥♥♥♥♥♥♥
- Created a shortcut to LaunchEFLC.exe in my desktop and set the shortcut to "Run as administrator". I can't set it directly on LaunchEFLC.exe.

And that's it, I can play now :D

Originally posted by =T$ECore= Niko:
Set gfwl to run as administrator.

I think GFWL is broken on Windows 8, I can't make it work properly.
Old Niko Jan 11, 2013 @ 3:22pm 
Set gfwl properties to run in compatible mode to Windows 7 and to run it as administrator. Is the so difficult?
Seijinho Jan 12, 2013 @ 7:02am 
Originally posted by =T$ECore= Niko:
Set gfwl properties to run in compatible mode to Windows 7 and to run it as administrator. Is the so difficult?

I've already tried that, but as I said, GFWL just doesn't work for me. I appreciate your help.
Pena McVesipossu Jan 12, 2013 @ 7:08am 
gta iv doesnt work on windows 8 you idoot, only on xp vista and 7
Old Niko Jan 12, 2013 @ 9:09am 
Originally posted by oskari2468:
gta iv doesnt work on windows 8 you idoot, only on xp vista and 7

I am running my GTA 4 on Windows 8 without any problem. Who is the bigger idiot?
Showing 1-15 of 42 comments
< >
Per page: 15 30 50