enes Jan 1, 2013 @ 12:25pm
"Could not write license data!"
Happy new years guys.Let's talk about my gta iv issue.I use Windows 7. I downloadeed the GTA IV from Steam and took my entire day.Now i want to play the game but I can't. When i clik to LaunchGTAIV.exe it says me "Could not write license data!Please contact Custumer Support for further instructions." tried to do the manual activation but still get the same error. Please guys, help me.
Showing 1-7 of 7 comments
< >
ButDoesItDrift?240 Jan 1, 2013 @ 1:17pm 
Steam has had alot of issues latley with gta4, I would contact them directly about the lisence issue though. Thats not really a fix you can do
enes Jan 1, 2013 @ 1:25pm 
Thanks for respond. I did contact them but I don't know how long i will wait for respond and I came here. And like you said have lot of issues and I looked on internet so many people have these issues. They need to do something for this.
ButDoesItDrift?240 Jan 1, 2013 @ 4:44pm 
They really do, I would expect a response tomorrow since today is new years and everythings closed hahaha
Adam Beckett Mar 11, 2013 @ 7:46am 
To everyone, who is googlebinging this same issue, a tip:

Go to your ~/GTAIV/Activation folder and execute SteamActivation.exe as admin.

Solves this problem immediately - without "customer support".
Deadly=uk= Apr 17, 2013 @ 4:25pm 
I had this error for both GTA4 and GTA:Episodes. I found then when the games the very first time I installed them, however the next day I got the "Could not write license data" securom error. I tried this fix as suggested by other forums but it did not work:

This step was from another forum for securerom problems:
1. Open the command line by pressing Start and selecting the Run... option.
2. Type cmd and push the [Enter] button on the keyboard.
3. Please type in rd /s "%APPDATA%\SecuROM" and press [Enter] on the keyboard.
4. Answer Y to the Y/N question and press [Enter] to complete the proces

What worked was the following
I found through a (perceived) separate issue was that I was having problem with some windows installers which was due to my temp folder not having the correct permission set up. I believe that the securom messes with the temp folder permissions in some manner.

To fix:
1. Click start and type in "%userprofile%\appdata\local" in to start
2. Right click temp, click properties and then the sharing tab.
3. Click edit and then add your username under "enter the object names to select" and click ok
4. Give your username full control under security and click ok.
Here is the same fix with pictures: http://store.steampowered.com



The game should now work!
The Bullshit Patrol Apr 30, 2013 @ 2:19pm 
I managed to fix it by simply opening the properties on \%userprofile%\appdata\local\temp\ and unchecking the "read-only" box.
Someone Dec 15, 2013 @ 6:54am 
Thanks to Deadly=uk=. Fixing the license issue per command line worked fine for me. Finally i can play GTA4 xD. Steam Support wasn't really helpful. Thanks again :D
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jan 1, 2013 @ 12:25pm
Posts: 7