Paratwa Apr 1, 2013 @ 8:58am
WINDOWS 8 - GTA 4 - To get working.
Windows 8 64 bit OS here. :)

I had problems with getting this to run; to solve I did the following.

***** Editted to add 4,5 and 6 and to note that I ran *all* of this, including the steam application under 'administrator rights' or 'run as administrator' *****

***** Editted again to add 7 ****

I went to the folder (may be just plain old Program files on your PC)
C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV

1.) then I installed C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\Installers\vcredist_x86.exe

2.) then I installed C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\Installers\gfwlivesetup.exe

3.) I then went to C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\GTAIV

and set the following ***3*** files to be ran in compatibility mode (Vista Service Pack 2) .
gta4Browser.exe
gtaEncoder.exe
GTAIV.exe

4.) Also went and downloaded this from http://www.xbox.com/en-US/LIVE/PC/DownloadClient didn't notice any difference though from the distro.

5.) I disabled the steam in game community link. (I have no idea if that made a difference, I just hate that thing).

6.) Also I ran the DirectX installers (as administrator) at C:\Program Files (x86)\Steam\steamapps\common\Grand Theft Auto IV\Installers

7.) ***Thanks to MSgt.N!nJ@2202*** go into your GTA IV directory, and Run LaunchGTAIV.exe as Administrator it works.
Last edited by Paratwa; Apr 1, 2013 @ 1:35pm
Showing 1-15 of 58 comments
< >
βlaze™ Apr 1, 2013 @ 9:12am 
Would this work with Windows 7 64bit?
jonathanpcrawford Apr 1, 2013 @ 9:13am 
..mine dont work either =/
Paratwa Apr 1, 2013 @ 9:14am 
Don't see why not man, wouldn't hurt to try, eh? :)
Snookie Apr 1, 2013 @ 9:15am 
the game starts but i get a fatal error saying that i should reinstall games for windows live... i did it but it is still coming this error :/
βlaze™ Apr 1, 2013 @ 9:15am 
Did u try this technique? if so what OS do u use? Windows 7?
Originally posted by jonathanpcrawford:
..mine dont work either =/
βlaze™ Apr 1, 2013 @ 9:16am 
Sure thing, I wouldnt like any more buggs/errors tho thats why im asking
Originally posted by Paratwa:
Don't see why not man, wouldn't hurt to try, eh? :)
Paratwa Apr 1, 2013 @ 9:18am 

Originally posted by Snookie:
the game starts but i get a fatal error saying that i should reinstall games for windows live... i did it but it is still coming this error :/

Try installing the newer version. http://www.xbox.com/en-US/LIVE/PC/DownloadClient

Originally posted by (-(-(-.-)-)-):
Did u try this technique? if so what OS do u use? Windows 7?
Originally posted by jonathanpcrawford:
..mine dont work either =/

I did this myself, yes, I am using windows 8. :)
βlaze™ Apr 1, 2013 @ 9:18am 
Did u use this technique on EFLC too?
Paratwa Apr 1, 2013 @ 9:23am 
Originally posted by (-(-(-.-)-)-):
Did u use this technique on EFLC too?

No sir, I was just bored and on a conference call, and saw that it didn't work, figured if it gave me a few minutes trouble then a general user would have loads of drama.

*note* I am betting if you have various versions of C++ distributions installed that *may* give you drama as well, unsure about that, this is my clean machine for playing so it had no drama, on my dev machines I am betting I would have had HUGE issues with that.

SO TLDR : if you still have drama uninstall C++ dists (knowing THIS MAY SCREW UP OTHER PROGRAMS --- of course they can be fixed by reinstalling C++ dists, no biggie) and install the vcredist_x86.exe as an admin.

I will download it later and see whats up with it (EFLC).

you can find the various versions later here at

http://www.microsoft.com/en-us/download/search.aspx?q=c%2b%2b+redistributable
βlaze™ Apr 1, 2013 @ 9:36am 
Nope, it did not work -.-
I tried to set it to windows 7 instead of vista service pack 2 aswell but still it didnt work, the game still wont start up after the social club window.
jonathanpcrawford Apr 1, 2013 @ 9:38am 
...mine will start but the graphics are rubbish and i cant change the settings..blox.
jonathanpcrawford Apr 1, 2013 @ 9:40am 
...no wonder it was £7.50 for the lot.. =(
βlaze™ Apr 1, 2013 @ 9:48am 
Indeed, ♥♥♥♥♥♥ rip off
Originally posted by jonathanpcrawford:
...no wonder it was £7.50 for the lot.. =(
Drebin Apr 1, 2013 @ 10:15am 
I tried this, but it did not work. I run win8, rebooted after I installed the second step of this solution, but nothing is launched after I click play.
Paratwa Apr 1, 2013 @ 10:24am 
Originally posted by Drebin:
I tried this, but it did not work. I run win8, rebooted after I installed the second step of this solution, but nothing is launched after I click play.

Did you happen to have any of the VC++ distributions in your programs and files? If so, you might try uninstalling them, of course with the caveat that you might have to REINSTALL them later to get other things to work.

This machine is just for playing so, yeah it doesn't matter if I do so on here. :-\
Showing 1-15 of 58 comments
< >
Per page: 15 30 50
Date Posted: Apr 1, 2013 @ 8:58am
Posts: 58