polmarc79 Apr 30 @ 3:43pm
GTA IV stutters, any help, ideas welcome. (780ti/4770k/8.1)
I have recently installed a 780 ti, and before I could actually start playing I had to add a commandline "-norestrictions" to the game files, because the game wouldn't recognize 3GB vram, ok that worked, was able to change settings etc.

But, while in game I get major stutter in game which makes it unplayable, its a constant stutter, I have tried changing settings, and it doesn't do any good, wether I set it low, medium or high. I had a GTX 770 and GTX 660 before and it played fine, even max settings with the 770. With the new card I experience major stuttering right at the start, with vsync off, I have over 50fps, but it stutters bad making it unplayable.

Now what is strange is that I also have a retail copy of GTA IV (DVD Disc) installed, and it plays perfectly fine, with no stutter at all. The only difference is I don't need steam to be running, and have to insert disk in order to play the game.

If anyone has faced similar situation, can you post back, and wether it was fixed or not or what fixed the issue. If I won't be able to fix this, I'll have to unistall this and stick to retail version, pretty sad for an older game to cause all the trouble, even with good hardware.
Last edited by polmarc79; Apr 30 @ 3:55pm
Showing 1-15 of 82 comments
< >
Trapper Apr 30 @ 8:06pm 
Launching the Steam version from the desktop icon instead of through Steam solved some really bad stuttering for me.
polmarc79 Apr 30 @ 8:39pm 
I'm reinstalling the game right now, I will try it out, thanks for the suggestion!
polmarc79 Apr 30 @ 10:46pm 
Tried launching it but it didn't work.

On the other hand played 2+ hours, from DVD, and absolutely no issues, I just don't get why the steam version stutters like crazy. Also my friend after adding a second 770 to his loop experiences the same issue, same exact stutter in game (steam).

I would just like to know what causes the stutter, if anyone has any other suggestions please post it, I'd appreciate it.

EFLC also stutters, if I won't fix this I'm going to have to buy the DLC on DVD too, since I only have the steam version.
Raskaipika Apr 30 @ 11:43pm 
Hi, try this:

-nomemrestrict -norestrictions

It´s the first post in this forum XD

GTA IV don´t recognize GPUs with VRAM above 2GB

http://steamcommunity.com/app/12210/discussions/0/558750985910076728/
Last edited by Raskaipika; Apr 30 @ 11:44pm
polmarc79 May 1 @ 2:58pm 
Originally posted by Raskaipika:
Hi, try this:

-nomemrestrict -norestrictions

It´s the first post in this forum XD

GTA IV don´t recognize GPUs with VRAM above 2GB

http://steamcommunity.com/app/12210/discussions/0/558750985910076728/


I already put the commandline -nomemrestrict in the GTA IV folder, so I could adjust the settings. My issue is that the game stutters even with 80+ fps in game.

I tried running the game on my older computer Q9550/GTX 260, which I used to play GTA IV on back in the day, and the same thing happens, the game stutters like crazy. All other games play fine on both computers, except the steam GTA IV.

Time to get DLC on DVD as the steam GTA IV is obvioulsy broken...
<HBS> Blazin540 May 1 @ 5:50pm 
I think maybe the Nvidia 337.50 BETA drives may be the issue with GTA IV as alot of the code was rewritten. Try uninstalling all drives and use the 335.23 WHQL drivers and u should be good to go, Good Luck!
polmarc79 May 1 @ 5:55pm 
Thanks for the suggestion, right now I'm running WHQL 335.23 driver, as I uninstalled the Beta 337. My older computer has older driver 331 or 332 and it stutters too.
<HBS> Blazin540 May 1 @ 6:10pm 
I juss recently downgraded my drivers, in thinking it would work, im downloading the game again as well, i'll let u know how it goes. I have a gtx 670, so i hope this works.
<HBS> Blazin540 May 1 @ 6:12pm 
mt gtx 650 ti ssc 2gb ran the game fine, i juss got my gtx 670 a few days ago and since i have had a weird in game lag as well, i hope someone finds a fix
polmarc79 May 1 @ 6:19pm 
So you're saying GTA IV lags with your new GTX 670?
Last edited by polmarc79; May 1 @ 6:21pm
<HBS> Blazin540 May 1 @ 6:20pm 
Also, i had to to Uninstal all nvidia drivers and then use driver fusion afterwards to get the rest of the files out, driver fusion is a requiremtn as driver files and registry files are left in the computer. When i first got my 670 i didnt uninstal nvidia drivers from my previous 650 ti ssc, the results were games were choppy and not as smooth as i'd hoped, i then i found out about driver fusion, it made my games run way smoother and not choppy but it didn't fix GTA IV unfortunately, juss wanted to share this information. P.S. Driver Fusion is Free.
<HBS> Blazin540 May 1 @ 6:21pm 
Yes the game runs laggy but not a lag like im used to its more like a skip in how the game displays on my screen or something is weird.
polmarc79 May 1 @ 6:23pm 
Mine stutters I think same thing as you're describing, skipping, I have over 60+ fps with vsync off in game, but it stutters, skips.
[UGL]NovaDust May 1 @ 9:19pm 
I'm getting the same exact problem, as of a few days ago. It feels like the image is skipping. Very annoying it's made the game unplayable for me.
polmarc79 May 1 @ 9:28pm 
Yes, what you are describing is happening to me and Blazin540 also it seems. Now it would be great to find a fix for this as like you said its completely unplayable.
Showing 1-15 of 82 comments
< >
Per page: 15 30 50
Date Posted: Apr 30 @ 3:43pm
Posts: 82