Skrofler Jul 2 @ 9:53am
[solved] Narrowing down the GFWL issue
Here's my story. I bought GTA4 a few days ago.
I use Windows 7-64 by the way.

First try to launch I get an actual error message with a numerical code (2000). Scour internet for solution. Seems to be Visual C++. Upon recommendation I install Visual C++ 2005. I only had 2008 and 2010 before.

Second try the game seems to work perfectly. At the title screen I enter the game and get a windowed message that I won't be able to save progress unless I sign in to GFWL. Then the intro starts, finishes, and I'm actually in the game. However, I want to be able to save so I exit.

After the restart I choose "sign in" from the title menu and learn that GFWL needs an update. The only previous time I used it was for Dawn of War II so that's reasonable.
Next I'm stuck in an infinity loop updating GFWL. It says updating and done. I launch the game and try to sign in, but apparently I still need to update GFWL. I try a few times, even restarting computer. No progress.

I proceed to uninstall GFWL and reinstall.

Now I can't launch the game at all. Like many others I get no error message and after declining to sign in to Social Club (like I always did) it just dies. Nothing happens.

Since then I've tried reinstalling GTA4 and then GFWL again (also GFWM). I have a hard time seeing how the problem is not directly related to the GFWL install since that's when the game stopped working. I'm out of ideas and I can't find anyone posting on any board about this particular issue.

Your thoughts?
Last edited by Skrofler; Jul 2 @ 1:10pm
Showing 1-14 of 14 comments
< >
r3fleCt ツ Jul 2 @ 10:08am 
u downloaded the newest GFWL client from the page?
Skrofler Jul 2 @ 10:16am 
Yes, whenever I install something I make sure to get it directly from the source.
There's something odd about that though. My version is 3.5.88 but I know there's a 3.5.95 version too. However, regardless if I download from xbox.com or microsoft.com I just get the same auto-installer that installas 3.5.88.
In any case, when the game was working I had an even earlier version so I should be able to run GTA4 anyway.
Razorbak86 Jul 2 @ 10:19am 
You need to download and install the latest version of the Games for Windows - LIVE ("GFWL") PC Client, which you can find on Microsoft's website. The older version of GFWL that is installed with this 6-year-old game is no longer compatible with modern operating systems (Win7/Win8). Below is the direct link to download the Games for Windows - LIVE PC Client...

http://go.microsoft.com/fwlink/?LinkID=201134

You can tell if you are running the updated version of GFWL by looking in the following location in your Control Panel...

On Win7: Control Panel > Programs > Programs and Features > Uninstall or Change a Program

There should be a program called "Microsoft Games for Windows - Live Redistributable" (Size: 31.3 MB, Version: 3.5.95.0) in your Programs listing.

Try that, and report back. Thanks.

Last edited by Razorbak86; Jul 2 @ 10:21am
Skrofler Jul 2 @ 10:26am 
I did exactly that, but the version is 3.5.88.

Update:
WTF? I tried again and now it's 3.5.92.
How can it install random version each time I install? I used the same installer all times.
Last edited by Skrofler; Jul 2 @ 10:30am
Razorbak86 Jul 2 @ 10:32am 
Does the game launch now? Does GFWL load? Does it let you save?
aisajib Jul 2 @ 10:33am 
@Razor, can you take a look at my issue? (FYI I downloaded that file but it fails to install telling me it can't connect. :/ my connection is alright and firewall is allowed through Steam.) http://steamcommunity.com/app/12210/discussions/0/46476144803299126/
Skrofler Jul 2 @ 11:02am 
No, the game still doesn't launch. I have no reason to believe I need any GFWL version to launch GTA4 since when I initially launched it I had version 3.1 and was never signed in to GFWL.
Last edited by Skrofler; Jul 2 @ 11:02am
aisajib Jul 2 @ 12:40pm 
I fixed mine although it was related to Social Club not GFWL. Not sure if that'll fix your issue, but you may wanna give it a try: http://aisjournal.com/2014/07/03/how-to-play-gta-iv-with-steam-on-windows-8/
Skrofler Jul 2 @ 1:09pm 
YEEEEEESSSSS! Thank you so much! It's working, although I use Win 7 and didn't change compatibility.
So what I needed all along was a .dll file. Makes me wonder why it wasn't installed in the first place, and why I'm not seeing messages on Rockstar support about this since it seems to be a common issue.
Razorbak86 Jul 2 @ 2:06pm 
FWIW, that process actually bypasses GFWL, so you probably won't be able to obtain achievements or play online multiplayer. I thought those things might be important to you, because you were attempting to update GFWL itself.
Skrofler Jul 2 @ 3:39pm 
Because I thought GFWL was the cause of the problem since the game stopped working when I updated GFWL manually.
No, I couldn't care less about achievements. Playing the game now and saving works fine. Thanks for your concern.
Razorbak86 Jul 2 @ 4:32pm 
Cool. Enjoy the game (again). :)
goishen Jul 2 @ 7:32pm 
Yah, I solved it. Stopped playing the game altogether. ♥♥♥♥ it. They wanna use GFWL? One less player.

aisajib Jul 3 @ 9:49am 
I'm glad to know that it's working for you guys, too. Pity that we can't play multiplayer with this fix, but do share the link with anyone you know having an issue.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Jul 2 @ 9:53am
Posts: 14