Dekaccho Nov 27, 2012 @ 9:16pm
Won't work on Windows 8
I'm running the 64 bit version.

Every time I try to launch after clicking on "Play", it crashes as soon as I get the launch and settings menu.

Any help?
Showing 1-15 of 28 comments
< >
Caron6440 Nov 28, 2012 @ 9:06pm 
Same with mine, i bought the max payne bundle and either game works, need help!
Dekaccho Dec 2, 2012 @ 4:55pm 
I "kind of" fixed it.

Go to the MP2 game folder and set its compatibility mode to Windows XP (Service Pack 3). Launching it directly will launch it successfully, but launching through Steam will just make it crash immediately.
Sam Dec 21, 2012 @ 4:46pm 
It could be because you're running 64 bit. Its an old game so 32 bit would probably be the best thing or you can click on the properties of the EXE and change the compatibility mode. Hope this helped! :3
Dekaccho Dec 21, 2012 @ 5:05pm 
I managed to solve this a while ago by making Xfire not detect the game. I think it also helps that I'm running Steam in Windows 7 compatbility mode.
Diamond Jan 1, 2013 @ 2:24pm 
even with compatbility mode steam tells me to turn it off until i turn it off it wont launch . but if i can get max payne 2 to work i get this error message http://prntscr.com/ntui2
Aedan762 Jan 2, 2013 @ 12:57am 
I solved it on my machine. Windows 8 Pro x64: Go to "xxSteam\steamapps\common\Max Payne 2 The Fall of Max Payne" -> Right-click on maxpayne2.exe -> Click "Properties" -> click the "Compatibility Tab" -> Drop down for "Compatability Mode" click "Windows 98/Windows ME" then click OK and then start from there, not Steam.
Marlowe Jan 2, 2013 @ 8:34am 
Hey guys, i solved on my machine (Windows 8 x64), too. First of all:

1- close steam;
2- terminate Max Payne 2 process.

Then follow these steps:
1- Go to "xxSteam\steamapps\common\Max Payne 2 The Fall of Max Payne" -> Right-click on maxpayne2.exe -> Click "Properties" -> click the "Compatibility Tab" -> Drop down for "Compatability Mode" click "Windows 98/Windows ME"

2- Start Max Payne 2;

3- In the configuration panel set Antialiasing: OFF. For other settings (resolution, texture, shadows) you can choose what you want, it does not matter. The important thing is to turn off anti-aliasing.

Hope I have been helpful.
Janstockers Feb 8, 2013 @ 11:06pm 
I solved problem on windoes 8 x64 for max payne 1 & 2

open steam and leave it open dont click on any of the maxpaynes on your steam library for some reason it works if i leave steam open,just leave it running in the background

Next go your steam folder,steamapps,common,max payne 2,right click on max payne 2.exe and click properties.click on compatibilty and set to windows 98/windows me and set apply.Now run the maxpayne2.exe from this folder as it wont work if you create a shortcut to your desktop or within the steam library itself.

Next once the max payne config panel is running set your graphics level to what ever you want as long as you turn antialiasing off as it wont work with it on

Hope this have solved problems
Marlowe Feb 9, 2013 @ 3:20am 
It 's the same solution I posted above.
Janstockers Feb 10, 2013 @ 11:55am 
yeah it is but i keep steam open you closed yours
AbesMapper 「₪」 Apr 27, 2013 @ 9:46pm 
I have the same problem but it's only works when I uninstalled my graphic drivers - AMD Vision Engine because I have laptop with Win 8, graphic acceleration and AMD Radeon™ HD 7340
Ikemefuna Apr 28, 2013 @ 9:13pm 
I had this problem on Max Payne 1 and 2. I changed the compatibility to Windows 98/ME as mentioned above. I also have an ATI card and had to rollback my driver to get it to work. I'm using 9.2.0.0 now and I was using 13.1 I believe. If you right click on Computer in the start menu, select properties, device manager, display adapters, then right click on your video card and select properties, go to driver and click roll back driver.

I did some other stuff to Max Payne 1, but this worked for 2 as well without doing any additional steps so hopefully that is all you need.

Good luck. This was so frustrating. I thought Steam checked for compatability with older games, but I guess not. Very disappointed...
thezemax May 12, 2013 @ 11:02am 
In my case with the trick of changing the compability mode to 98/ME it appears to me the following message:

Exception in startupInit:Directory \data not found

What can I do from here???
nNa Jun 6, 2013 @ 11:45am 
Originally posted by thezemax:
In my case with the trick of changing the compability mode to 98/ME it appears to me the following message:

Exception in startupInit:Directory \data not found

What can I do from here???

I have the same issue. (Windows 8 x64).
thezemax Jun 7, 2013 @ 7:05am 
yeah actually that message is the same with me...
still no response from steam or rockstar...very disappointed with this
Showing 1-15 of 28 comments
< >
Per page: 15 30 50